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The domain is not listed when you try to add new users to Business Portal


Symptoms

When you try to add new users to Business Portal, the domain may not be listed.

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Cause

Business Portal cannot access the domain controller.

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Resolution

Make sure that you can ping the domain controller for the domain that is not listed in Business Portal. Use the ping command on the server that is running Business Portal. Make sure that you can ping by its NetBios name.

To use the ping command, follow these steps on the server that is running Business Portal:
  1. Click Start, click Run, type cmd, and then click OK.
  2. To ping by name, follow these steps:
    1. Type the following command:
      ping SERVERNAME
      Note Replace SERVERNAME with the name of the domain controller.
    2. Press ENTER.

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Workaround

If you are running Microsoft Business Portal 2.0, Microsoft Business Portal 2.5, or Microsoft Business Portal 2.5 Feature Pack (Business Portal 2.7), use method 1. If you are running Business Portal 3.0, use method 2.

Method 1: Use the Security Setup utility to add the users from the domain that is not listed in Business Portal

To run the Security Setup utility, follow these steps:
  1. Locate the bin folder of the Web site that you have Business Portal installed. By default, this is located at C:\Inetpub\wwwroot\bin.
  2. Double-click the SecuritySetupUtility.exe.
    Note To run this utility you must logon to the server as the person who installed Business Portal.

Method 2: Manually add an entry to the BusinessFramework.config file

  1. In Windows Explorer, locate the BusinessFramework.config file. By default, this file is located at C:\Inetpub\wwwroot\bin.
  2. Open the file by using a text editor such as Notepad.
  3. Add the following entry to the file:
    <Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>
    <useAlternativeDomainLookup type="Boolean" value="True”/>
    </Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>

    Here is a section of what the file should look like after you add the entry:

    <Microsoft.BusinessFramework.Security.SecureApplicationDirectoryList>
    <directoryList type="String" value="/sites/BusinessPortal/|/BusinessPortal/"/>
    </Microsoft.BusinessFramework.Security.SecureApplicationDirectoryList>

    <Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>
    <useAlternativeDomainLookup type="Boolean" value="True"/>
    </Microsoft.BusinessFramework.Portal.Administration.ActiveDirectoryReaderConfig>

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More Information

Steps to reproduce the problem

  1. Start Business Portal.
  2. Click Site Settings, click Users and Permissions, click Manage Business Portal Users, and then click Add new users.
  3. In the Add Users window, click Next.
No domain is listed in the Domain list, or some domains are not listed.

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Keywords: kbmbspartner, kbsolomonbp, kbgreatplainsbp, kbmbsmigrate, kbprb, kb

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Article Info
Article ID : 914166
Revision : 1
Created on : 3/25/2017
Published on : 7/14/2012
Exists online : False
Views : 85