Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error messages when you use the .NET Framework 2.0 on the same server as Microsoft Dynamics CRM 3.0: "Reports.config has invalid schema, and could not be loaded. 0x80632900" and "Server Application Unavailable"


Symptoms

Symptom 1

If you use the .NET Framework 2.0 on the same server that has Microsoft Dynamics CRM 3.0 installed, you may receive one of the following error messages:
Error message 1
Reports.config has invalid schema, and could not be loaded. Error Number: 0x80632900 Request URL: http://server/CRMReports/home_reports.aspx Stack Trace: [CRMException: Reports.config has invalid schema, and could not be loaded] Microsoft.Crm.Reports.ReportTypeCache.ValidationErrorHandler(Object sender, ValidationEventArgs e) +34 System.Xml.Schema.BaseValidator.SendValidationEvent(XmlSchemaException e, XmlSeverityType severity) +58
Note You receive this error message when you try to open a Microsoft Dynamics CRM 3.0 report.
Error message 2
Server Application Unavailable The web application you are attempting to access on this web server is currently unavailable. Please hit the "Refresh" button in your web browser to retry your request. Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.
Note You receive this error message when you try to open the Microsoft Dynamics CRM 3.0 Web site.

The following error message is listed in the application event log:
It is not possible to run two different versions of ASP.NET in the same IIS process. Please use the IIS Administration Tool to reconfigure your server to run the application in a separate process. For more information, see Help and Support Center at http://support.microsoft.com.

Symptom 2

When you click Track in CRM in Microsoft CRM Sales for Outlook laptop client or desktop client, you receive the following error message:
You do not have enough privileges to access the Microsoft CRM object or perform the requested operation. For more information, contact your system administrator

↑ Back to the top


Cause

This problem occurs because a Microsoft Dynamics CRM 3.0 virtual directory is running the .NET Framework 2.0. This can occur if Microsoft SQL Server 2005 Reporting Services and the .NET Framework 2.0 are installed manually before Microsoft Dynamics CRM 3.0 is installed.

↑ Back to the top


Resolution

To resolve this problem, follow these steps.

Step 1: Change the Microsoft ASP.NET version to 1.1.4322

  1. On the Microsoft CRM server, click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
  2. Expand Computer, expand Web sites, and then select Microsoft CRM v3.0 Web site.
  3. On the Action menu, click Properties.
  4. On the ASP.NET tab, locate the ASP.NET version box, click 1.1.4322, and then click OK.

    Note This tab appears only after you install the .NET Framework 2.0.
  5. Expand Microsoft CRM v3.0 Web site. Then select MSCRMServices.
  6. On the Action menu, click Properties.
  7. On the ASP.NET tab, locate the ASP.NET version box, click 1.1.4322, and then click OK.

Step 2: Change the ASP.NET status to Allow

To do this, follow these steps:
  1. Log on to the Microsoft CRM server as a user who has a local administrator role.
  2. Click Start, click All Programs, click Administrative Tools, and then click Internet Information Services (IIS) Manager.
  3. In IIS Manager, expand the server name.
  4. Click Web Service Extensions.
  5. In the Web Service Extensions folder, right-click ASP.NET v1.1, and then click Allow.

Step 3: Reset IIS

Click Start, click Run, type iisreset, and then click OK.

↑ Back to the top


More information

Microsoft CRM 1.2 and 1.0 deployments do not support Microsoft .NET Framework 2.0. Therefore, remove the Microsoft .NET Framework from the Microsoft CRM server and from all Microsoft CRM client computers.

↑ Back to the top


Keywords: KB914079, kbprb, kbmbsmigrate, kbmbsinstallation, kberrmsg, kbtshoot, kbmbscrm40no

↑ Back to the top

Article Info
Article ID : 914079
Revision : 6
Created on : 6/20/2014
Published on : 6/20/2014
Exists online : False
Views : 110