Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Error message when you try to start a COM+ application on a computer that is running Windows Server 2003 with Service Pack 1: "Catalog Error An error occurred while processing the last operation"


View products that this article applies to.

Symptoms

When you try to start a Microsoft COM+ application on a computer that is running Microsoft Windows Server 2003 with Service Pack 1, you may receive an error message that is similar to the following:
<Error>
Catalog Error
An error occurred while processing the last operation.
Error code 80080005 - Server execution failed.
The event log may contain additional troubleshooting information.
</Error>

↑ Back to the top


Cause

This problem occurs because you use a fully qualified domain name (FQDN) that has more than 16 characters when you configure the account under which the COM+ application runs.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2003 installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 SP1, Itanium architecture
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.26283,999,74428-Jan-200602:58IA-64SP1Not applicable
Rpcss.dll5.2.3790.2628859,13628-Jan-200602:58IA-64SP1Not applicable
Wole32.dll5.2.3790.26281,247,74428-Jan-200602:58x86SP1WOW
Windows Server 2003 SP1, x64
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.26282,547,20028-Jan-200602:58x64SP1Not applicable
Rpcss.dll5.2.3790.2628697,85628-Jan-200602:58x64SP1Not applicable
Wole32.dll5.2.3790.26281,247,74428-Jan-200602:58x86SP1WOW
Windows Server 2003 SP1, x86
File nameFile versionFile sizeDateTimeSP requirement
Ole32.dll5.2.3790.26281,247,74428-Jan-200603:37SP1
Rpcss.dll5.2.3790.2628421,88828-Jan-200603:37SP1

↑ Back to the top


Workaround

To work around this problem, do not use a FQDN when you configure the account under which the COM+ application runs. Instead, type the domain and the user name in the form domain\username.

To view the account under which the COM+ application runs, follow these steps:
  1. Click Start, click Run, type Dcomcnfg.exe, and then click OK.
  2. Expand Component Services, expand Computers, expand the computer that you want, and then expand COM+ Applications.
  3. Right-click the COM+ application you want, and then click Properties.
  4. On the Identity tab, note the account information in the User box.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

After you apply this hotfix, the User box on the Identity tab has a 512-character limit. You can type the domain and the user name in the form domain\username, or you can use a FQDN.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Article Info
Article ID : 913677
Revision : 3
Created on : 1/1/0001
Published on : 1/1/0001
Exists online : False
Views : 507