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You may experience network connection problems on a Windows XP SP2-based computer or a Windows Server 2003 SP1-based computer that has more than one network adapter


View products that this article applies to.

Symptoms

You are using a Microsoft Windows XP Service Pack 2 (SP2)-based computer or a Microsoft Windows Server 2003 Service Pack 1 (SP1)-based computer that has more than one network adapter. If the Windows Firewall is enabled, you may experience network connection problems on this computer. These connection problems occur even if you have added the following items to the Windows Firewall exception list:
  • The application that tries to make the connection
  • The protocol that is used to make the connection
Additionally, information that resembles the following appears in the Firewall log:
DateTime DROP Protocol Src-IP Dst-IP Src-Port Dst-Port Size - - - - - - - SEND
Note The information is available only if the Firewall log is enabled in the Windows Security Center. Log information is stored in the %systemroot%\Pfirewall.log file.

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Cause

This problem may occur if the following conditions are true:
  • A multi-homed computer receives a network packet on a network adapter (adapter1).
  • The IP destination of the packet is the IP address of another network adapter (adapter2).
In this case, the response to the network packet may be dropped. The anti-spoofing rule examines each send packet to see whether the sending IP address is bound to the adapter1. The answer packet is dropped because the sending IP address is bound to adapter2.

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Resolution

Windows XP

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
There are no prerequisites to install this hotfix.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Service Pack 2 (SP2)-based versions
File nameFile versionFile sizeDateTimePlatform
Ipnat.sys5.1.2600.2831135,68021-Jan-200601:18x86

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

Prerequisites
To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ipnat.sys5.2.3790.2745103,42412-Jul-200610:21x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ipnat.sys5.2.3790.2745156,16012-Jul-200617:34x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ipnat.sys5.2.3790.2745350,20812-Jul-200617:34IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB913522, kbqfe, kbHotfixServer, kbbug, kbfix, kbwinserv2003sp2fix, kbautohotfix

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Article Info
Article ID : 913522
Revision : 5
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 251