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No records are imported when you use the Bulk Import feature in Microsoft Dynamics CRM


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Symptoms

You use the Bulk Import feature in Microsoft Dynamics CRM 3.0 to create multiple records. After you import the batch of data, the Bulk Import activity has a status of "pending." However, no records are imported. Additionally, an error message that is similar to the following is logged in the Application event log on the Microsoft CRM server:
FAILED to start process 'A06FEC80-6C61-4DFF-8D26-BB629DC898BD' for object: (4406,{5BE7870F-6B72-DA11-9A85-001143CD0420}). Caller is 'SYSTEM'. Error code 80048306.

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Cause

This problem occurs for one or more of the following reasons:
  • The Microsoft Dynamics CRM Workflow service and the CRM application pool (CRMAppPool) in Internet Information Services (IIS) are not running under the same account. See Resolution 1 in the "Resolution" section.
  • The GUID values in the OrganizationBase table for the System user or for the Integration user differ from the GUID values in the SystemUserBase table. See Resolution 2 in the "Resolution" section.

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Resolution

Resolution 1

Configure the CRM application pool and the Workflow service to run under the Network service account. To configure the CRM application pool, follow these steps:
  1. Click Start, point to Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
  2. Expand local computer, expand Application Pools, right-click CRMAppPool, and then click Properties.
  3. Click the Identity tab, and then click Predefined.
  4. Select Network Service from the list, and then click OK.
  5. Right-click CRMAppPool, and then click Stop.
  6. Right-click CRMAppPool, and then click Start.
  7. Close IIS Manager.
To configure the Workflow service, follow these steps:
  1. Click Start, click Run, type services.mmc, and then click OK.
  2. Right-click Microsoft CRM Workflow Service, and then click Stop.
  3. Right-click Microsoft CRM Workflow Service, click Properties, and then click the LogOn tab.
  4. Click This Account, type NTAUTHORITY\NETWORK SERVICE, and then click OK.
  5. Right-click Microsoft CRM Workflow Service, and then click Start.
If the CRM application pool and the Workflow service are both starting under the same account, you may have to restart the Workflow service. To restart the Workflow service, follow these steps:
  1. Log on to the Microsoft CRM server as a system administrator user.
  2. Click Start, click Run, type services.msc, and then click OK.
  3. Right-click Microsoft CRM Workflow Service.
  4. Click Start. Alternatively, click Restart if the Workflow service has already been started.

Resolution 2

Verify the GUID values for the System user and for the Integration user. To verify the GUID values, follow these steps:
  1. On the computer that is running Microsoft SQL Server and on which the Microsoft Dynamics CRM databases are stored, click Start, point to All Programs, point to Microsoft SQL Server 2005, and then click SQL Server Management Studio.
  2. In the list of databases, verify that OrganizationName_MSCRM is selected.
  3. Click New Query.
  4. Copy the following queries, and then paste them into the New Query window.
    SELECT TOP 1 SystemUserId FROM SystemUserBase WHERE SystemUserBase.LastName = 'SYSTEM'
    select SystemUserId from organizationbase
  5. To run the query, click Execute.
  6. Verify that the GUID values that are returned from the queries are the same value.
  7. Copy the following queries, and then paste them into the New Query window.
    SELECT TOP 1 SystemUserId FROM SystemUserBase WHERE SystemUserBase.LastName = 'INTEGRATION'
    select integrationuserid from organizationbase
  8. To run the query, click Execute.
  9. Verify that the GUID values that are returned from the queries are the same value.
If the values from the queries are different, contact Technical Support for Microsoft Dynamics to resolve this problem. For information about technical support for Microsoft Dynamics CRM, visit the following Microsoft Web site:

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Keywords: KB913517, kbprb, kbmbsmigrate, kberrmsg, kbmbsworkflow, kbmbscrm40no

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Article Info
Article ID : 913517
Revision : 4
Created on : 10/22/2007
Published on : 10/22/2007
Exists online : False
Views : 424