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The Outlook 2003 toolbar does not appear, and you receive an error message when you start Outlook 2003 on a computer that is running Microsoft Dynamics CRM 3.0


View products that this article applies to.

Symptoms

When you start Microsoft Office Outlook 2003 on a computer that is running Microsoft Dynamics CRM 3.0, you receive one of the following error messages:
An error occurred loading Microsoft CRM functionality. Try restarting Microsoft Outlook. Contact your system administrator if the errors persist.
There is a problem communicating with the Microsoft CRM server. The server might be unavailable. Try again later. If the problem persists, contact your system administrator.
When you click OK to the error message, Outlook 2003 starts but the standard Outlook 2003 toolbar does not appear. If you click a Microsoft CRM folder in Outlook 2003, the program works correctly.

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Cause

Cause 1

This issue may occur if Microsoft XML Core Services (MSXML) 4.0 Service Pack 2 (SP2) is not installed or the installation is corrupted.

Cause 2

This issue may occur if the MSXML components have trouble communicating with the Microsoft CRM Outlook client.

Cause 3

This issue may occur if there is an unexpected line of code in the Isv.config.xml file. For example, this issue may occur if the following line of code appears in the Isv.config.xml file:
xml version="1.0" encoding="Windows-1252"
Because there is an unexpected line of code, the file cannot be successfully parsed. When the Outlook client tries to load its forms, the Outlook client cannot build the form because it has a malformed XML document.

Cause 4

This issue may occur if the Microsoft CRM 3.0 Web site is using the Microsoft .NET Framework version 2.0 instead of .NET Framework version 1.1.4322.

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Resolution

Resolution 1

To resolve this issue, repair or install MSXML 4.0 SP2.

How to repair MSXML 4.0 SP2

  1. Click Start, point to Control Panel, and then click Add or Remove Programs.
  2. In the Currently installed programs list, locate MSXML 4.0 SP2 Parser.
  3. Click MSXML 4.0 SP2 Parser, click Change, and then click Next.
  4. Click Repair, and then click Install.

How to install MSXML 4.0 SP2

  1. Download and install MSXML 4.0 SP2. To do this, visit the following Microsoft Web site:
  2. After the installation of MSXML 4.0 SP2 has completed, restart the client computer.
Start Outlook 2003 and determine whether the error message occurs. If the issue persists, remove and then reinstall the Microsoft CRM desktop client for Microsoft Office Outlook. To do this, follow these steps:
  1. Click Start, point to Control Panel, and then click Add or Remove Programs.
  2. In the Currently installed programs list, locate Microsoft CRM desktop client for Microsoft Office Outlook.
  3. Click Microsoft CRM desktop client for Microsoft Office Outlook, and then click Change.
  4. Follow the instructions to uninstall the Microsoft CRM desktop client for Outlook.
  5. Restart the computer.
  6. Reinstall the Microsoft CRM desktop client for Outlook by using the program CD-ROM.

Resolution 2

To resolve this issue with MSXML, follow these steps:
  1. On the Tools menu in Outlook 2003, click Customize, click Toolbars, click to select the Microsoft CRM check box, click Delete, click to select the Menu Bar check box, and then click Reset.
  2. In the Outlook 2003 folders, delete all the folders in the Microsoft CRM folder.
  3. In Outlook 2003, delete all the Microsoft CRM shortcuts.
  4. Close Outlook 2003.
  5. Delete the UIXmlHash registry key from the HKCU\Software\Microsoft\MSCRMClient registry hive.
  6. Make sure that the RCOffline value is set to 0 in the HKCU\Software\Microsoft\MSCRMClient registry hive.
  7. Start Outlook 2003.

Resolution 3

To resolve this issue, follow these steps:
  1. Close the Microsoft CRM Outlook client.
  2. Open the Isv.config.xml file in Notepad, and then delete the first line in the file.

    Notes
    • The Isv.config.xml file is in the Resources folder on the Microsoft CRM server.
    • The first line in the Isv.config.xml file should be the following line:
      <?xml version="1.0" encoding="Windows-1252"?>
  3. Save the Isv.config.xml file.
  4. Open the Web.config file in Notepad, and then set the ISVIntegration value attribute to "All".

    Notes
    • The Web.config file is on the Microsoft CRM server.
    • The ISVIntegration value attribute includes the quotation marks. After you change the ISVIntergration value, it appears as follows:
      <add key="ISVIntegration" value="All"/>
  5. Save the Web.config file.
  6. Start the Microsoft CRM Outlook client.

Resolution 4

To resolve this issue, set the Microsoft CRM 3.0 Web site to use the .NET Framework version 1.1.4322. To do this, follow these steps:
  1. On the Microsoft CRM server, click Start, click Run, and then type inetmgr.
  2. Expand Web Sites, right-click Microsoft CRM v3.0, and then click Properties.
  3. Click the ASP.NET tab, and then change the .NET Framework to version 1.1.4322.
  4. Expand Microsoft CRM v3.0, right-click MSCRMServices, and then click Properties.
  5. Click the ASP.NET tab, and then change the .NET Framework to version 1.1.4322.
  6. Restart Microsoft Internet Information Services (IIS). To do this, type IISRESET at the command prompt.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
910090� Error message when you try to start Microsoft Outlook after you install the Microsoft Dynamics CRM client for Outlook: "There is a problem communicating with the Microsoft CRM Server"

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Keywords: KB913509, kbprb, kbmbsmigrate, kberrmsg, kbmbscrm40no

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Article Info
Article ID : 913509
Revision : 4
Created on : 9/11/2006
Published on : 9/11/2006
Exists online : False
Views : 417