Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A program that allocates a large block of contiguous memory may not start or may intermittently fail in Windows Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a program that allocates a large block of contiguous memory in Microsoft Windows Server 2003. For example, this program allocates a 1.5-gigabyte (GB) block of memory when the program starts or after it starts.
  • This program loads the Hnetcfg.dll library.
In this scenario, the program may intermittently not start. Or, after the program starts, you may experience intermittent program failures. If you troubleshoot these program failures, you may determine that they occur because the program could not successfully allocate the large block of contiguous memory.

↑ Back to the top


Cause

This problem occurs because the Hnetcfg.dll library has an image base address of 5F270000. If the Hnetcfg.dll library is loaded at this address, you may experience memory fragmentation of the Windows user address space. You experience this fragmentation because the Hnetcfg.dll library is loaded at approximately 1.6 GB into the address space.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must be running Microsoft Windows Server 2003 Service Pack 1 (SP1) to apply this hotfix.

Note x64-based versions of Windows Server 2003 include SP1.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Hnetcfg.dll5.2.3790.2625351,74425-Jan-200603:26x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hnetcfg.dll5.2.3790.2625574,46425-Jan-200602:47x64SP1SP1QFE
Whnetcfg.dll5.2.3790.2625351,74425-Jan-200602:47x86SP1WOW
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hnetcfg.dll5.2.3790.26251,093,63225-Jan-200602:47IA-64SP1SP1QFE
Whnetcfg.dll5.2.3790.2625351,74425-Jan-200602:47x86SP1WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbwinserv2003sp2fix, kbwinserv2003presp2fix, kbhotfixserver, kbbug, kbfix, kbqfe, KB913409

↑ Back to the top

Article Info
Article ID : 913409
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 266