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The Chkdsk.exe utility incorrectly identifies and resets security descriptors in Windows Server 2003


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003-based computer, consider the following scenario. You run the Chkdsk.exe utility in fix mode. You use the /f switch, the /x switch, or the /r switch with this command. In this scenario, you find that the access control lists (ACLs) on some files may revert to their default values.

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Cause

This problem occurs because of an exception that occurs when the NTFS file system transaction log is full and when security descriptors are being updated. In this scenario, the security descriptors can be left in an incorrect state. If you then run Chkdsk again, this will cause the security descriptor entries to be reset to their default value of Full Control for the Administrators group and Full Control for the SYSTEM user account.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Note Service Pack 1 is included in x64-based versions of Windows Server 2003.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.490572,92822-Feb-200601:27x86
Windows Server 2003, x86-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.2644589,82422-Feb-200603:20x86
Windows Server 2003, x64-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.26441,124,35221-Feb-200612:31x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.4901,695,74421-Feb-200612:26IA-64
Windows Server 2003, Itanium-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Ntfs.sys5.2.3790.26441,882,11221-Feb-200612:30IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

The problem occurs because under certain circumstances the Chkdsk.exe utility incorrectly identifies security descriptors as corrupted and therefore resets them to the default value. Entries that resemble the following appear in the Chkdsk.exe utility log:
CHKDSK is verifying security descriptors (stage 3 of 3)...
Repairing the security file record segment.
Deleting an index entry with Id 8447 from index $SII of file 9.
Deleting an index entry with Id 31126 from index $SII of file 9.
Deleting an index entry with Id 50636 from index $SII of file 9.
Deleting an index entry with Id 31126 from index $SDH of file 9.
Deleting an index entry with Id 50636 from index $SDH of file 9.
Deleting an index entry with Id 8447 from index $SDH of file 9.
Replacing invalid security id with default security id for file 1461234.
Security descriptor verification completed.
Windows found problems with the file system. 
Notes
  • This hotfix prevents future corruption. It does not fix existing corruption. Recreating the volumes after Windows Server 2003 SP2 or this hotfix is installed will prevent the problem. Contact Microsoft Product Support Services (PSS) to help troubleshoot existing corruption.
  • The number of reported errors and the security IDs may vary. The index entry IDs and the file numbers may also vary. This problem may occur on large volumes with as many as 4,194,303 or more files.
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
831374 The CHKDSK utility incorrectly identifies and deletes in-use security descriptors

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Keywords: KB913034, kbqfe, kbfix, kbbug, kbwinserv2003sp2fix, kbautohotfix

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Article Info
Article ID : 913034
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 437