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FIX: Out of memory exceptions may occur when you run an application that is built by using the .NET Framework 2.0 in a high-load environment


Symptoms

When you run an application that is built by using the Microsoft .NET Framework 2.0, out of memory exceptions may occur. This problem may occur when the following conditions are true:
  • The application uses the System.Management namespace together with Microsoft Windows Management Instrumentation (WMI) objects to update content.
  • You run the application in a high-load environment.

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Cause

This problem occurs because the .NET garbage collector (GC) does not always dispose of WMI objects immediately.

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Resolution

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next .NET Framework 2.0 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have the .NET Framework 2.0 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTime
System_management.dll2.0.50727.71368,64009-Feb-200609:47

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Workaround

To work around this problem, frequently call the GC.WaitForPendingFinalizers method manually.

Note Calling the GC.WaitForPendingFinalizers method manually may reduce application performance.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbfix, kbhotfixserver, kbqfe, kbpubtypekc, kbprb, kbupdate, kb, kbentirenet

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Article Info
Article ID : 912884
Revision : 3
Created on : 3/30/2017
Published on : 3/30/2017
Exists online : False
Views : 100