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You may receive a "Stop 0x00000024" error message when you use an application to extend a partition on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

When you use an application to extend a partition on a Microsoft Windows Server 2003-based computer, you may receive a Stop error message that is similar to the following:
A problem has been detected and windows has been shut down to prevent damage to your computer.

If this is the first time you've seen this Stop error screen, restart your computer. If this message appears again, follow these steps:

Disable or uninstall any anti virus , disc defragmentation or backup utilities. Check your hard drive configuration, and check for any updated drivers. Run CHKDSK /F to check for hard drive corruption, and then restart your computer.

Technical Information

Stop 0x00000024 (0x0019033c, 0xf016e7a0, 0xf016e49c, 0xe061dcdc)

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Cause

This problem may occur if the application uses the following IOCTLS and FSCTLS control codes to extend the volume:
IOCTL_DISK_UPDATE_PROPERTIES
IOCTL_DISK_GROW_PARTITION
FSCTL_EXTEND_VOLUME
For example, you may use a third-party utility to resize a partition or to append unused space on a hard disk to an existing partition. If the third-party utility uses these IOCTLS and FSCTLS control codes, a Stop error may occur.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ftdisk.sys5.2.3790.2607137,21604-Jan-200602:16x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ftdisk.sys5.2.3790.2607240,12804-Jan-200604:38x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ftdisk.sys5.2.3790.2607499,20004-Jan-200604:38IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbexpertiseinter, kberrmsg, kbqfe, kbhotfixserver, KB912848

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Article Info
Article ID : 912848
Revision : 9
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 309