Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you update or delete entities by using Microsoft Dynamics CRM SDK and impersonation support: �Server was unable to process request�


View products that this article applies to.

Symptoms

Consider the following scenario in Microsoft Dynamics CRM:
  • You create a customization that calls the Microsoft Dynamics CRM Web service and then sets credentials to request impersonation support.
  • You try to update or to delete an instance of an entity by using the methods that are outlined in the Microsoft CRM Software Development Kit.
When you try to update or to delete the entity, the custom application returns the following SoapException error message:
Server was unable to process request.

↑ Back to the top


Cause

The access level of the assign privilege is not sufficiently deep for the user who is specified in the impersonated credentials. Therefore, the update or the delete operation fails.

Note The impersonated user must have the appropriate access level of the assign privilege to update or to delete the entity when the following conditions are true:
  • You are updating all the attributes for this instance of the entity.
  • The ownerid attribute is included among the attributes that you are updating.

↑ Back to the top


Resolution

To resolve this problem, use one of the following methods:

Method 1

In the Settings area of Microsoft CRM, open the role to which the impersonated user belongs. Then raise the access level of the assign privilege for the entities that are modified programmatically by the custom application.

Method 2

Modify the custom application so that the ownerid attribute from this instance of the entity is not included in the object that is passed to the update method or to the delete method.

Note When you include the ownerid attribute, Microsoft CRM performs an internal assign operation that requires specific assign privileges. When you remove the ownerid attribute from the object that is passed to the Microsoft CRM method, the program does not perform this internal assign operation.

↑ Back to the top


More information

You can access additional error message information by writing code to catch the thrown exception. If you do this when you try to update or to delete this instance of the entity, the following text appears in the OuterXml property of the error message details:
Error Code: 0x80048306
Description: Not enough privilege to access the Microsoft CRM object or perform the requested operation.

↑ Back to the top


Keywords: kbmbscustomization, kbmbscrmonlinesdk, kbmbscrmonline, kbmbscrm40, kberrmsg, kbmbsmigrate, kbprb, kbfreshness2008, KB912687

↑ Back to the top

Article Info
Article ID : 912687
Revision : 6
Created on : 9/7/2006
Published on : 9/7/2006
Exists online : False
Views : 510