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Event ID 50, 26, or 57 is logged when you use HP SecurePath on a computer that is running Windows Server 2003 Service Pack 1 (SP1) or an x64 edition of Windows


View products that this article applies to.

Symptoms

You use Hewlett-Packard (HP) SecurePath on a computer that is running Microsoft Windows Server 2003 Service Pack 1 (SP1) or an x64 edition of Windows. In this situation, one or more of the following event IDs is logged in the System log:
Event Type: Warning
Event Source: Ntfs
Event Category: None
Event ID: 50
Time: Date
Time: Time
User: N/A
Computer: Computer_Name
Description:
{Delayed Write Failed} Windows was unable to save all the data for the file . The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

For more information, see Help and Support Center at http://support.microsoft.com.
Data:
0000: 00040004 00520002 00000000 80040032
0010: 00000000 c000003c 00000000 00000000
0020: 00000000 00000000 c000003c
For more information about event ID 50, click the following article number to view the article in the Microsoft Knowledge Base:
816004 Description of the event ID 50 error message
Event Type: Information
Event Source: Application Popup
Event Category: None
Event ID: 26
Time: Date
Time: Time
User: N/A
Computer: Computer_Name
Description:
Application popup: Windows - Delayed Write Failed : Windows was unable to save all the data for the file DRIVE:\FILE. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

For more information, see Help and Support Center at http://support.microsoft.com.
Event Type: Warning
Event Source: Ftdisk
Event Category: Disk
Event ID: 57
Time: Date
Time: Time
User: N/A
Computer: Computer_Name
Description:
The system failed to flush data to the transaction log. Corruption may occur.

For more information, see Help and Support Center at http://support.microsoft.com.
Data:
0000: 00000000 00be0001 00000002 80040039
0010: 00000000 c000003c 00000000 00000000
0020: 00000000 00000000
Errors that are related to this issue contain a status code of c000003c in the logged event. This status code is also known as STATUS_DATA_OVERRUN. Logged events that do not contain a status code of c000003c have a different cause and are not related to this issue.

On Microsoft server clusters (MSCS) you might see that cluster nodes intermittently cannot reserve the shared disks. In Event Viewer you may see the following entries:
Event Type: Error
Event Source: ClusSvc
Event Category: Physical Disk Resource
Event ID: 1038
Date: 27.04.2006
Time: 05:44:22
User: N/A
Computer: Computer_Name
Description:
Reservation of cluster disk 'Cluster_disk_name:' has been lost. Please check your system and disk configuration. For more information, see Help and Support Center at http://support.microsoft.com.
In a software tracing log of the clusdisk driver and in the cluster logs you will also see the following logs:

04\27\2006-05:44:19:752 ReserveScsiDevice(8A622408): Exit => STATUS_SUCCESS :
04\27\2006-05:44:20:361 GetDriveLayoutEx failed for DO 8A6154E0, 0xc00000a3 (STATUS_DEVICE_NOT_READY)
04\27\2006-05:44:20:408 GetDriveLayoutEx failed for DO 8A620528, 0xc00000a3 (STATUS_DEVICE_NOT_READY)
04\27\2006-05:44:20:424 GetDriveLayoutEx failed for DO 8A61DBA0, 0xc00000a3 (STATUS_DEVICE_NOT_READY) :
04\27\2006-05:44:22:752 ClusDiskReservationWorker: LostReserve DO 8A622408 DiskNo 3 status 0xc000003c (STATUS_DATA_OVERRUN) (operation 0)

The cluster log will report the following events at the same time:

2006/04/27-03:44:22.752 INFO Physical Disk <Disk_Name:>: [DiskArb] CompletionRoutine, status 1117.
2006/04/27-03:44:22.752 ERR Physical Disk <Disk_Name:>: [DiskArb] CompletionRoutine: reservation lost! Status 1117
2006/04/27-03:44:25.533 ERR Physical Disk <Disk_Name:>: LooksAlive, error checking device, error 1117.
2006/04/27-03:44:25.533 ERR Physical Disk <Disk_Name:>: IsAlive, error checking device, error 1117. This is seen sporadically and does not show up in the boot phase of the cluster nodes.

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Cause

This problem occurs because of changes that were made to the Classpnp.sys file in Windows Server 2003 SP1. These changes were also incorporated into the x64-based versions of Windows. These changes caused a compatibility issue with the Raidisk.sys driver in HP SecurePath.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

Prerequisites

You must be running Windows Server 2003 SP1 to install this hotfix.

Note x64-based versions of Windows do not require Windows Server 2003 SP1 to install this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix. During the installation of this hotfix, the following services are automatically stopped and then restarted.
HTTP SSL
IIS Admin Service
HTTP SSL
Microsoft Exchange Routing Engine
Simple Mail Transfer Protocol (SMTP)
World Wide Web Publishing Service

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Classpnp.sys5.2.3790.260054,78422-Dec-200523:58x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Classpnp.sys5.2.3790.260098,30423-Dec-200501:19x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Classpnp.sys5.2.3790.2600161,28023-Dec-200501:19IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site: The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: kbwinserv2003sp2fix, kbhotfixserver, kbqfe, kbexpertiseadvanced, kberrmsg, KB912593

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Article Info
Article ID : 912593
Revision : 8
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 388