Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You may receive an NDR when you send an e-mail message to an external X400 address through a Defense Messaging System gateway server in Exchange Server 2003 SP2


View products that this article applies to.

Symptoms

Consider the following scenario. You are working in an organization that is running Microsoft Exchange Server 2003 Service Pack 2 (SP2). You send an e-mail message to an external X400 address. This e-mail message is routed through a Defense Messaging System (DMS) gateway server. In this scenario, you may receive a non-delivery report (NDR).

This issue occurs when the e-mail message is also routed over an X400 connector.

↑ Back to the top


Cause

This issue occurs because an e-mail message is encapsulated two times when it is also routed over an X400 connector. When the e-mail message is encapsulated two times, the PrintableString representation of the at sign (@) may be split between two Exchange Domain Defined attribute (DDA) extension markers. When this occurs, the message transfer agent (MTA) sends an NDR.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you install the hotfix.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mtaroute.dll6.5.7651.667,07221-Feb-200602:10x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

The X400 address printable character set uses T.61 extended characters. In this character set, the at sign is represented as �(a)�. If the string that represents the at sign is split between two DDA extension markers, the string is represented as one of the following strings:
  • (a;DDA:MSXCHNGE=)
  • (;DDA:MSXCHNGE=a)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

↑ Back to the top


Keywords: KB912582, kbbug, kbfix, kbqfe, kbhotfixserver, kbautohotfix, kbarchive, kbnosurvey

↑ Back to the top

Article Info
Article ID : 912582
Revision : 3
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 355