Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

When a hardware malfunction occurs on a computer that is running an x64 Edition version of Windows, you do not receive a Stop error message, and no memory dump file is generated


View products that this article applies to.

Symptoms

On a computer that is running an x64 Edition version of Microsoft Windows, you do not receive a Stop error message when a hardware malfunction occurs. Additionally, no memory dump file (Memory.dmp) is generated. Instead, the computer just stops responding (hangs).

Without the Stop error parameters or the memory dump file, you may not be able to diagnose the cause of the hardware malfunction.

↑ Back to the top


Cause

This problem occurs if a Non-Maskable Interrupt (NMI) is issued when a hardware malfunction occurs on a computer that is running an x64 Edition version of Windows. This problem is unlikely to occur outside a testing environment.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Hal.dll5.2.3790.2611279,04006-Jan-200623:07x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

↑ Back to the top


Keywords: KB912364, kbhotfixserver, kbqfe, kbexpertiseinter, kbwinserv2003sp2fix

↑ Back to the top

Article Info
Article ID : 912364
Revision : 7
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 280