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The "Getting the domain information" part of the GPResult.exe command-line process takes a long time to finish on a member server that is running Windows Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario. You run the Group Policy Results (GPResult.exe) command-line tool on a member server. The member server is running Microsoft Windows Server 2003. In this scenario, the "Getting the domain information" part of the tool's execution process takes a long time to finish. For example, this part of the process may take several minutes or more to finish.

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Cause

This problem occurs when you run the Group Policy Results tool in an Active Directory forest where one or both of the following conditions are true:
  • There are many domains in the forest.
  • Many trusts in the forest are configured to external domains.
This problem occurs because the Group Policy Results tool parses every trust in the forest as part of the process to verify all the policy settings. If the Group Policy Results tool encounters one or more domains that are not reachable, the process takes longer to finish.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 32-bit editions
File nameFile versionFile sizeDateTimePlatform
Gprslt.exe5.2.3790.2645142,84823-Feb-200608:54x86
Windows Server 2003, x64 editions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gprslt.exe5.2.3790.2645206,84823-Feb-200612:07x64SP1SP1QFE
Wgprslt.exe5.2.3790.2645142,84823-Feb-200612:07x86SP1WOW
Windows Server 2003 for Itanium-based systems
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gprslt.exe5.2.3790.2645420,86423-Feb-200612:06IA-64SP1SP1QFE
Wgprslt.exe5.2.3790.2645142,84823-Feb-200612:06x86SP1WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbbug, kbfix, kbqfe, kbhotfixserver, KB912263

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Article Info
Article ID : 912263
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 305