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Error message when you try to change the default company for a user in Business Portal 3.0 or in Microsoft Business Portal 2.5: "Error: Access is denied"


Symptoms

When you try to change the default company for a user, you receive the following error message:
Internet Explorer Script Error

An error has occurred in script on this page. Line: 127 Char: 3 Error: Access is denied Code: 0 URL: http://XXX/businessportal/portal/administration/AC_DefaultCompany.aspx?UserID=GUID
In this error message, GUID represents the GUID of the user for whom you tried to change the default company.

This problem occurs in Business Portal 3.0 in Microsoft Dynamics GP, in Business Portal 3.0 in Microsoft Dynamics SL, and in Microsoft Business Solutions Business Portal 2.5.

Note You only receive this error message when you try to change the default company of a user who does not have the Administrator role assigned.

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Cause

This issue occurs because the Default Company field is a user-defined field and not an administrator-defined field. Therefore, because the user does not have the Administrator role assigned, you cannot change that user's default company on the Site Settings tab in Business Portal 3.0 or in Microsoft Business Portal 2.5.

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Resolution

To resolve this issue, use one of the following methods.

Method 1: Let the user change the default company

The individual user can change his or her default company by using the My Settings option in Business Portal 3.0, in Microsoft Business Portal 2.5, or in Microsoft Business Portal 2.5 Feature Pack.

Method 2: Temporarily assign the Administrator role to the user

Important These steps may increase your security risk. These steps may also make your computer or the network more vulnerable to attack by malicious users or by malicious software such as viruses. We recommend the process that this article describes to enable programs to operate as they are designed to, or to implement specific program capabilities. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this process in your particular environment. If you choose to implement this process, take any appropriate additional steps to help protect the system. We recommend that you use this process only if you really require this process.

To modify the default company for a non-administrative user, follow these steps:
  1. Assign the Administrator role to the user for whom you want to change the default company:
    1. Log on to Business Portal 3.0 or to Microsoft Business Portal 2.5.
    2. Click Site Settings, and then click Manage Business Portal users under Users and Permissions.
    3. In the User List, click the non-administrative user for whom you want to change the default company.
    4. In the User Properties pane, click Modify next to the Portal Roles list.
    5. In the Modify Roles -- Web Page Dialog box that appears, click to select the Administrator check box, and then click OK.
  2. Change the default company for that user in Business Portal 3.0 or in Microsoft Business Portal 2.5.
  3. Remove the Administrator role from this user.

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More Information

Steps to reproduce the behavior

  1. Log on to Business Portal 3.0 or to Microsoft Business Portal 2.5.
  2. Click the Site Settings tab, and then click Manage Business Portal Users.
  3. Click a non-administrative user, and then try to modify the default company for that user.
You receive the error message that is mentioned in the "Symptoms" section.

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Keywords: kbmbspartner, kbtshoot, kberrmsg, kbmbsmigrate, kbprb, kb

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Article Info
Article ID : 912095
Revision : 1
Created on : 3/25/2017
Published on : 7/14/2012
Exists online : False
Views : 91