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You receive an error message when you click "Go Offline" in the Microsoft Dynamics CRM client for Microsoft Office Outlook


View products that this article applies to.

Symptoms

Symptom 1

When you click Go Offline in the Microsoft Dynamics CRM client 3.0 for Microsoft Office Outlook, you receive the following error message:
Exception from HRESULT: 0x80040220
To work around this problem, see Workaround 1.

Symptom 2

You do not see an error in Microsoft Dynamics CRM for Microsoft Office Outlook; however, the following error appears in the Event Viewer:
An error occurred initializing a process that triggers Microsoft CRM actions based on Outlook events. Some synchronization or tagging actions may not occur. Try restarting Microsoft Outlook. HR=0x8007000e. Context=. Function=CEnableState::Activate. Line=63.


To work around this problem, see Workaround 1.

Symptom 3

When you click Go Offline in Microsoft Dynamics CRM for Microsoft Office Outlook, you receive the following error message:
Error going offline "Microsoft Visual C++ Debug Library. Debug Assertion Failed!"
Program: C:\Program Files\Microsoft Office\Office 12\Outlook.exe
File: c:\bt\1149\src\application\outlook\addin\downloaddata.cpp
Line: 299
You can click any button in the dialog box. If you click Ignore in the dialog box, the offline client goes offline.

If you click Retry in the dialog box, Outlook closes. Additionally, the offline client stays online.

If you click Abort in the dialog box, Outlook closes. Additionally, the offline client stays online.

To work around this problem, see Workaround 2.

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Cause

This problem occurs because the user does not have the Sync to Outlook privilege in the Microsoft Dynamics CRM security role.

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Workaround

Workaround 1

To go offline, the user must have the Sync to Outlook privilege in the Microsoft CRM security role. To add this privilege, follow these steps:
  1. In Microsoft Dynamics CRM, click Settings, click Settings, click Business Unit Settings, click Users, and then double-click the user to open the user record.
  2. Click Roles, and then double-click the security role to open the security role that is assigned to the user.
  3. Click the Business Management tab, and then verify the Sync to Outlook option is selected.

    Note If the user is in a child business unit, you must make the role change at the top level business unit. The change will then roll down to the sub business units.
To make the role change at the top level business unit, follow these steps.

Note To make this role change, use the role that you used in the previous procedure.
  1. In Microsoft Dynamics CRM, click Settings, click Settings, click Business Unit Settings, and then click Security Roles.
  2. In the list, click the top level business unit, and then open the security role that is assigned to the user.
  3. Click the Business Management tab, and then verify that Sync to Outlook is selected.

Workaround 2

To go offline, click Ignore in the dialog box.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbmbscrmonlineoutlook, kbfreshness2008, kbmbscrm40, kbtshoot, kberrmsg, kbmbsmigrate, kbbug, kbmbscrmonline, KB911379

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Article Info
Article ID : 911379
Revision : 4
Created on : 1/7/2008
Published on : 1/7/2008
Exists online : False
Views : 461