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Exchange Server 2003 may generate NDRs for messages that are routed to another organization when you connect Exchange Server 2003 to multiple organizations by using X.400 connectors


View products that this article applies to.

Symptoms

Consider the following scenario. You connect Microsoft Exchange Server 2003 to multiple organizations by using X.400 connectors. These organizations use third-party mail transfer agents (MTAs). In this scenario, Exchange Server 2003 may generate non-delivery reports (NDR) for some messages that are sent to the third-party MTA if the destination server of the primary X.400 connector is unavailable. You expect Exchange Server 2003 to deliver messages to the destination MTA over the secondary X.400 connector if the destination server of the primary X.400 connector is unavailable.

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Cause

This problem occurs if a message includes a private extension in the message envelope. Exchange Server 2003 identifies a private extension in the message envelope by using an object identifier instead of an integer. This behavior does not strictly comply with the 1988 X.400 standards. According to these standards, an object identifier can be used to identify a private extension in the message envelope only in and between private management domains (PRMDs). However, only an integer can be used to identify a private extension in the message envelope in an administrative management domain (ADMD). Therefore, a third-party MTA that strictly enforces the X.400 protocol may reject a message that contains a private extension in the message envelope if that message is routed to another organization.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the Microsoft Exchange Information Store service together with its dependant services are automatically stopped and then restarted when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mdbmsg.dll6.5.7234.43,269,63203-Mar-200623:31x86
Redir.aspNot applicable3,30429-Jan-200620:50Not applicable
Store.exe6.5.7234.45,201,40804-Mar-200600:03x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

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Keywords: KB911029, kbexchange2003presp2fix, kbbug, kbfix, kbHotfixServer, kbqfe, kbautohotfix, kbarchive, kbnosurvey

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Article Info
Article ID : 911029
Revision : 4
Created on : 1/14/2015
Published on : 1/14/2015
Exists online : False
Views : 376