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The IIS Admin Service (Inetinfo.exe) crashes and mail builds up in the SMTP queue on a computer that is running Exchange Server 2003


View products that this article applies to.

Symptoms

You may experience the following symptoms on a computer that is running Microsoft Exchange Server 2003:
  • The IIS Admin Service (Inetinfo.exe) crashes. In this situation, the following event is logged in the System log:

    Event Type: Error
    Event Source: Service Control Manager
    Event Category: None
    Event ID: 7031
    Date: date
    Time: time
    User: N/A
    Computer: ServerName
    Description: The IIS Admin Service service terminated unexpectedly. It has done this 2 time(s). The following corrective action will be taken in 1 milliseconds: Run the configured recovery program.

  • Mail builds up in the SMTP queue.
If you turn off the message tracking component in Exchange, you no longer experience this problem.

Note You may experience this problem more frequently on a heavily loaded Exchange gateway server.

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Cause

This problem occurs because of a problem in the message tracking component in Exchange. The message tracking component may crash when it tries to obtain the properties of a Mailmsg object. This problem occurs because a thread that queues a message for remote delivery runs at the same time as the message tracking thread that logs the event that states that the message is queued for remote delivery. This problem occurs in the following situation:
  • Exchange queues a message for remote delivery.
  • The message tracking thread starts to log an event that states that the message is queued for remote delivery.
  • The message is delivered and then removed by a different thread.
  • The message tracking thread tries to obtain the properties of the Mailmsg object that was removed to finish the logging operation.
In this situation, the message tracking component crashes when it tries to obtain the properties of the Mailmsg object because the Mailmsg object has been removed.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, you must be running Exchange Server 2003 Service Pack 2 (SP2) to install this hotfix.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993� How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart Microsoft Internet Information Services (IIS) and all the Exchange Server 2003-related services after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Phatq.dll6.5.7651.4599,04014-Feb-200603:36x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903� New naming schema for Exchange Server software update packages

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Keywords: KB910618, kbbug, kbfix, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 910618
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 261