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An Exchange Server 2003 virus-scanning program does not obtain sender information from an e-mail message that the program receives from an Exchange Server 5.5 user


View products that this article applies to.

Symptoms

You use a virus-scanning program that accesses the Microsoft Exchange Server 2003 virus-scanning API (VSAPI 2.0 or VSAPI 2.5) to scan e-mail messages in your organization. The virus-scanning program does not obtain sender information from e-mail messages if the following conditions are true:
  • You have a mixed-mode organization that consists of Exchange Server 2003 servers and Microsoft Exchange Server 5.5 servers.
  • The virus-scanning program processes messages that the program receives from an Exchange Server 5.5 server that is in the same administrative group.
In this situation, all the following properties are missing from the received message or messages:
  • PR_SENDER_NAME
  • PR_SENDER_ADDRTYPPE
  • PR_SENDER_EMAIL_ADDRESS

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Cause

This problem occurs because the Exchange Server 2003 VSAPI expects the sender properties to exist on the e-mail message envelope. This expectation is valid for an SMTP-based e-mail message transfer between servers. However, this expectation is not valid for an X400-based e-mail message transfer between servers.

By default, the connection between Exchange Server 5.5 and Exchange Server 2003 uses the X400 protocol. Therefore, the Exchange Server 2003 VSAPI does not successfully obtain the sender information when the VSAPI scans e-mail messages from users who are hosted on servers that use X400 connectors to connect to Exchange Server 2003. This situation includes the implicit X400 connector that Exchange Server 5.5 uses to communicate with Exchange Server 2003.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Exchange Server 2003 Service Pack 2 (SP2) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Store.exe6.5.7650.165,248,00022-Dec-200504:21x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903� New naming schema for Exchange Server software update packages

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Keywords: KB910188, kbpubtypekc, kbexchange2003presp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbautohotfix

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Article Info
Article ID : 910188
Revision : 6
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 270