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The system stops responding when you access a Web page or open an HTML document on a Windows XP SP2-based computer


View products that this article applies to.

Symptoms

When you use Microsoft Internet Explorer 6 to access a Web page or to open an HTML document on a Windows XP SP2-based computer, the system stops responding. Additionally, you notice that the CPU usage is almost 100%.

This issue may occur if the Web page or the HTML document has a RUBY element. For example, when you open the Web page by using the HTML editor, some lines of the source code resemble the following:
<ruby>123<rt style='layout-grid-mode:line'>abc</rt>A</ruby>
Note This issue also occurs when you use Microsoft Outlook Express to open an HTML-formatted e-mail message that contains a RUBY element.

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Cause

When Internet Explorer 6 parses the line that contains the RUBY element, an infinite loop occurs. The infinite loop causes this problem.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll6.0.2900.27713,017,72807-Oct-200516:59x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

A ruby is an annotation or pronunciation guide for a string of text. The string of text that is annotated with a ruby is known as the base. For more information about the RUBY element, visit the following Microsoft Web site: For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB908917, kbexpertiseinter, kbexpertisebeginner, kbqfe, kbhotfixserver, kbfix, kbbug, kbautohotfix

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Article Info
Article ID : 908917
Revision : 2
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 318