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The System Information tool may report the incorrect number of logical processors on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

Consider the following scenario. You use the System Information tool (Msinfo32.exe) to view the processor information on a Microsoft Windows Server 2003-based computer. The Windows Server 2003-based computer uses hyperthreading-enabled processors or dual-core processors. In this scenario, the System Information tool may report an incorrect number of logical processors.

Note To open the System Information tool, click Start, click Run, type msinfo32.exe, and then click OK.

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Cause

This problem may occur if the number of logical processors exceeds the architectural limit of the operating system. For example, this problem may occur when the following conditions are true:
  • The computer on which this problem occurs is running Microsoft Windows Server 2003, Datacenter x64 Edition.
  • This computer uses more than 32 hyperthreading-enabled processors or more than 32 dual-core processors.
In this scenario, the system uses more than 64 logical processors. However, Windows Server 2003, Datacenter Edition supports no more than 64-way symmetric multiprocessing.

Note In this scenario, a data structure that is used to hold the processor information may not be initialized correctly. Therefore, unpredictable behavior may occur, such as the behavior that is mentioned in the "Symptoms" section.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix on x86-based versions of Windows Server 2003, you must have Service Pack 1 (SP1) installed. No prerequisites are required for x64-based versions of Windows Server 2003.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Halaacpi.dll5.2.3790.2556116,73626-Oct-200500:30x86SP1
Halacpi.dll5.2.3790.255682,94426-Oct-200500:30x86SP1
Halmacpi.dll5.2.3790.2556118,27226-Oct-200500:30x86SP1
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Hal.dll5.2.3790.2556279,04026-Oct-200519:45x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information about Windows Server 2003 features, visit the following Microsoft Web page:

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB908522, kbhotfixserver, kbqfe, kbexpertiseadvanced, kbwinserv2003sp2fix, kbautohotfix

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Article Info
Article ID : 908522
Revision : 9
Created on : 3/28/2007
Published on : 3/28/2007
Exists online : False
Views : 318