Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

One or more site objects may be missing after you expand a site hierarchy node in a remote System Management Server 2003 Administrator Console


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You expand the site hierarchy node in a remote Microsoft Systems Management Server (SMS) 2003 Administrator Console.
  • The console site is connected to a site whose SMS Windows Management Instrumentation (WMI) provider is installed on a Microsoft Windows Server 2003-based computer.
In this scenario, the site hierarchy node may be missing for one or more site objects. This problem may also occur after you update the site hierarchy node.

↑ Back to the top


Cause

During the initial client request to populate the site hierarchy node, the server responds with the incorrect remote procedure call (RPC) port. Therefore, the data is never received by the client, and the site hierarchy node is empty. The problem occurs when the RPC port restriction is enabled by using the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\Internet
For more information about how to configure RPC port restrictions, click the following article number to view the article in the Microsoft Knowledge Base:
154596 How to configure RPC dynamic port allocation to work with firewalls

↑ Back to the top


Resolution

To resolve this problem, obtain the latest service pack for Microsoft Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Installation instructions

The service pack must be installed on the server where the SMS WMI provider (Smsprov.dll) is installed. To determine which server hosts the SMS WMI provider, examine the Provider Location registry value under the following registry subkey on the SMS site server:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Setup

↑ Back to the top


Workaround

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this problem, follows these steps:
  1. On the remote computer that is running the SMS Administrator Console, click Start, click Run, type regedit, and then press ENTER.
  2. Locate and then right-click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\Internet
  3. Click Delete to delete the Internet key and to remove the RPC port restrictions.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack Service Pack 1.

↑ Back to the top


Keywords: KB908478, kbprb, kbtshoot, kbbug, tools, kbsmsremote, kbsmsadmin

↑ Back to the top

Article Info
Article ID : 908478
Revision : 4
Created on : 10/27/2006
Published on : 10/27/2006
Exists online : False
Views : 340