Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Windows Server 2003-based computer may use a paging file on a system disk instead of the intended non-local paging file


View products that this article applies to.

Symptoms

A Microsoft Windows Server 2003-based computer may use a paging file on a system disk instead of the intended non-local paging file when the following conditions are true:
  • The non-local paging file was configured on a dynamic disk.
  • The Windows Server 2003 system disk is a basic disk.

↑ Back to the top


Cause

This issue occurs because the dynamic disk subsystem may get into a timing problem that prevents it from correctly enumerating the available drive letters at start time. Therefore, the dynamic disk is not available for paging.

↑ Back to the top


Resolution

To resolve this issue, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Locate and then click the following registry subkey:
    HKLM\SYSTEM\CurrentControlSet\Services\dmboot
  2. In the right-hand pane, double-click Start, and then type 0.
Note This resolution does not work for more than one computer restart because the dmboot.sys driver reads the registry entry that is listed in step 1 and is disabled (set to 0x4) again if the startup disk is not dynamic.

↑ Back to the top


Workaround

To work around this issue, configure the paging file on a basic disk, rather than on a dynamic disk.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
175761 Dynamic versus basic storage in Windows 2000

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

↑ Back to the top


Keywords: kbtshoot, kbprb, KB908371

↑ Back to the top

Article Info
Article ID : 908371
Revision : 8
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 302