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An access violation is generated when a Linux-based client computer tries to access a domain controller that is running Windows Server 2003 or Windows 2000


View products that this article applies to.

Symptoms

When you add a Linux-based client computer to a domain controller that is running Microsoft Windows Server 2003 or Microsoft Windows 2000, heap corruption occurs on the domain controller. This heap corruption deletes data from valid memory addresses and generates an access violation. This behavior occurs when the client computer tries to access valid data on the domain controller.

Note This access violation causes the domain controller to crash.

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Cause

This behavior occurs when the following conditions are true:
  • The client computer tries to access the domain controller by using Lightweight Directory Access Protocol (LDAP) bind calls.
  • The LDAP bind calls use encryption buffers that are smaller than the encryption block size.

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Resolution

Windows Server 2003 service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Ntdsa.dll5.2.3790.4374,058,11202-Nov-200513:43IA-64RTMQFE
Ntdsatq.dll5.2.3790.43782,43202-Nov-200513:43IA-64RTMQFE
Ws03res.dll5.2.3790.43765,02402-Nov-200510:54IA-64RTMQFE
Wws03res.dll5.2.3790.43765,53602-Nov-200511:06x86WOW
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Ntdsa.dll5.2.3790.4371,427,96803-Nov-200503:13x86RTMQFE
Ntdsatq.dll5.2.3790.43729,69603-Nov-200503:13x86RTMQFE
Ws03res.dll5.2.3790.43765,53603-Nov-200500:36x86RTMQFE

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Windows 2000 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Windows 2000 Service Pack 3 (SP3) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Kerberos.dll5.0.2195.7072208,65602-Nov-200509:37x86
Ntdsa.dll5.0.2195.7072938,76802-Nov-200510:25x86
Secur32.dll5.0.2195.707247,37602-Nov-200510:25x86
Sp3res.dll5.0.2195.70706,386,68823-Sep-200504:10x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbqfe, kbhotfixserver, kbwinserv2003presp2fix, kbbug, kbfix, kbwin2000presp5fix, KB907868

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Article Info
Article ID : 907868
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 280