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A computer that is running an x64-based version of Windows Server 2003 may stop responding when you try to synchronize PCI devices


View products that this article applies to.

Symptoms

A computer that is running an x64-based version of Microsoft Windows Server 2003 may stop responding when you try to synchronize Peripheral Component Interconnect (PCI) devices that control printers, copiers, or press interfaces.

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Cause

This problem occurs when interrupt requests conflict on a device driver that specifies the highest DIRQL value in the SynchronizeIrql parameter of the IoConnectInterrupt routine. This conflict results in an unreported deadlock condition.

Windows multichannel digital printers, copiers, and press interfaces rely on the value that is specified in the SynchronizeIrql parameter.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntkrnlmp.exe5.2.3790.25434,418,56007-Oct-200514:59x64SP1
Ntoskrnl.exe5.2.3790.25434,446,20807-Oct-200514:59x64SP1

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Status

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information about how to use the IoConnectInterrupt routine, visit the following Microsoft Web site:For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB907723, kbwinserv2003presp1fix, kbqfe, kbfix, kbbug, kbexpertiseinter, kbwinserv2003sp2fix, kbautohotfix

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Article Info
Article ID : 907723
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 383