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32-bit applications may not be initialized and installed correctly for a new user on a 64-bit version of Windows Server 2003


View products that this article applies to.

Symptoms

When you install a 32-bit application on a computer that is running a 64-bit version of Microsoft Windows Server 2003, you may find that the 32-bit application is not initialized and installed correctly for a new user who logs on to the computer.

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Cause

This problem occurs because of the way that the active setup registry subkeys define installed components. Every time that a user logs on, the operating system examines these subkeys to make sure that the user initiates all the applications. The operating system examines these subkeys by running a user-independent setup string.

By default, The application settings are defined in the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup\Installed Components
When a 32-bit application installs, it adds itself to the registry in the following registry subkey:
HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Active Setup\Installed Components
When a user logs on to a computer that is running a 64-bit version of Windows Server 2003, only the 64-bit registry subkeys are examined. The Wow6432Node registry entry is ignored. Therefore, 32-bit applications are not installed correctly.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Windows Server 2003 with Service Pack 1.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x64-based versions with Service Pack 1

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformService branch
Shdocvw.dll6.0.3790.25692,434,56011-Nov-200511:45x64Not Applicable
Wshdocvw.dll6.0.3790.25691,513,47211-Nov-200511:45x86WOW

Windows Server 2003, Itanium-based versions with Service Pack 1

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shdocvw.dll6.0.3790.25693,680,25611-Nov-200511:45IA-64SP1Not Applicable
Wshdocvw.dll6.0.3790.25691,513,47211-Nov-200511:45x86SP1WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB907660, kbqfe, kbhotfixserver, kbfix, kbbug, kbwinserv2003sp2fix, kbautohotfix

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Article Info
Article ID : 907660
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 271