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Extended file attributes of NFS-shared files that reside on an SIS-enabled volume are missing in Windows Storage Server 2003 R2


View products that this article applies to.

Symptoms

Consider the following scenario. You have a Microsoft Windows Storage Server 2003-based computer that contains Network File System (NFS)-shared files. These NFS-shared files reside on a volume that has Single Instance Store (SIS) functionality enabled.

In this scenario, the extended file attributes of the NFS-shared files are missing.

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Cause

This problem occurs because of interoperability issues between SIS and NFS-shared files that have extended file attributes. The extended file attributes are lost when the NFS files are groveled.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Update information

The following files are available for download from the Microsoft Download Center:
Release Date: December 2, 2005

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit x86-based versions
   Date         Time   Version           Size  File name
   --------------------------------------------------------
   23-Sep-2005  08:54  5.2.3790.2534   83,456  Grovel.exe
   23-Sep-2005  09:10  5.2.3790.2534   83,456  Grovel.exe
   23-Sep-2005  09:06  5.2.3790.2534   32,256  Arpidfix.exe
   13-Jul-2005  00:34  6.1.22.4       371,936  Updspapi.dll
Windows Server 2003, 64-bit Itanium-based versions
   Date         Time   Version           Size  File name     Platform
   ------------------------------------------------------------------
   23-Sep-2005  04:38  5.2.3790.2534  247,296  Grovel.exe    IA-64
   23-Sep-2005  04:38  5.2.3790.2534  247,296  Grovel.exe    IA-64
   23-Sep-2005  04:38  5.2.3790.2534   74,752  Arpidfix.exe  IA-64
   23-Sep-2005  04:38  6.1.22.4       639,712  Updspapi.dll  IA-64
Windows Server 2003, 64-bit x64-based versions
   Date         Time   Version           Size  File name
   --------------------------------------------------------
   23-Sep-2005  04:38  5.2.3790.2534  146,432  Grovel.exe
   23-Sep-2005  04:38  5.2.3790.2534  146,432  Grovel.exe
   23-Sep-2005  04:38  5.2.3790.2534   43,008  Arpidfix.exe
   23-Sep-2005  04:38  6.1.22.4       462,560  Updspapi.dll

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Workaround

To work around this problem, do not enable SIS on the volume where you plan to store the NFS-shared files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information about the description of the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

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Keywords: atdownload, kbwinserv2003sp2fix, kbqfe, kbtshoot, kbbug, kbfix, KB907565

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Article Info
Article ID : 907565
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 620