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Error message when you try to view reports in Microsoft Dynamics CRM 3.0: "The request failed with HTTP status 401: Unauthorized"


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Symptoms

Consider the following scenario. You install the Microsoft Dynamics CRM server software by using a configuration of four computers (computers A, B, C, and D). All the computers are running Windows Server 2003. Additionally, the computers are configured as follows:
  • Computer A has the Microsoft Dynamics CRM server software installed.
  • Computer B has Microsoft SQL Server installed.
  • Computer C has Microsoft SQL Server Reporting Services (SSRS) installed.
  • Computer D is a domain controller.
After you install the Microsoft Dynamics CRM server software, you cannot view reports in Microsoft Dynamics CRM. When you try to access the reports area, you are prompted to enter a user name and a password. After you enter this information, you receive the following error message:
The request failed with HTTP status 401: Unauthorized.
Additionally, if you enabled Microsoft Dynamics CRM platform tracing, you may notice error messages that resemble the following messages in the w3wp-CRMWeb log:
MSCRM Application Error Report:
Error: Exception of type System.Web.HttpUnhandledException was thrown.
Error Message: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
Error Details: Exception of type System.Web.HttpUnhandledException was thrown.
Source File: Not available
Line Number: Not available
Request URL: URL
Stack Trace Info:
at System.Web.UI.Page.HandleError(Exception e)
at System.Web.UI.Page.ProcessRequestMain() at System.Web.UI.Page.ProcessRequest()
at System.Web.UI.Page.ProcessRequest(HttpContext context)
at System.Web.CallHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)Exception of type System.Web.HttpUnhandledException was thrown.
at System.Web.UI.Page.HandleError(Exception e)
at System.Web.UI.Page.ProcessRequestMain()
at System.Web.UI.Page.ProcessRequest()
at System.Web.UI.Page.ProcessRequest(HttpContext context)
at System.Web.CallHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Microsoft.Crm.ReportingServices.ReportingService.GetResourceContents(String Resource, String& MimeType)
at Microsoft.Crm.Reports.ReportCache.get_CategoryList() at Microsoft.Crm.Reports.Home.ConfigurePage()
at Microsoft.Crm.Application.Controls.AppPage.OnPreRender(EventArgs e) at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain()

Type: Application
at ErrorInformation.LogError() at ErrorInformation..ctor(Exception exception, Uri requestUrl)
at MainApplication.Application_Error(Object sender, EventArgs e) at EventHandler.Invoke(Object sender, EventArgs e)
at HttpApplication.RaiseOnError() at HttpApplication.RecordError(Exception error)
at HttpApplication.ResumeSteps(Exception error)
at HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) at HttpRuntime.ProcessRequest(HttpWorkerRequest wr)
at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)
Note The URL placeholder represents the actual value of the SQLRSServerURL registry entry. For example, the value could be the following:
http://IPAddress: PortNum/CRMReports/home_reports.aspx
The IPAddress placeholder represents the actual IP address. The PortNum placeholder represents the actual port number.

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Cause

This problem may occur if one or more of the following conditions are true:
  • The Microsoft Dynamics CRM server software was not restarted after the installation was finished.
  • The time settings on the four computers are not the same.
  • The SQLRSServerURL registry entry points to an incorrect IP address instead of to the host name of the computer on which Reporting Services is installed.

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Resolution

To resolve this problem, follow these steps:
  1. Restart the Microsoft Dynamics CRM server software. To do this, follow these steps:
    1. Log on to the Microsoft Dynamics CRM server software.
    2. Click Start.
    3. Click Shutdown.
    4. Click Restart, and then click OK.
  2. Correct the time and date settings on each computer. To do this, follow these steps:
    1. Log on to each computer.
    2. Click Start, point to Settings, point to Control Panel, and then click Date and Time.
    3. Correct the time and the time zone for each computer.
    4. Click OK.
  3. Manually change the value of the SQLRSServerURL registry entry to use the host name of the computer that is running Reporting Services.
    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate the following registry subkey:
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM
    3. Right-click SQLRSServerURL, and then click Modify.
    4. Change the value of the SQLRSServerURL registry entry to be the host name of the computer that is running Reporting Services. For example, in the Value data box, type the following value, and then click OK:
      http://Host_Name/ReportServer
      Note The Host_Name placeholder represents the actual name of the computer that is running Reporting Services.

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Keywords: KB907487, kbprb, kberrmsg, kbmbsmigrate, kbmbsreports, kbmbscrm40no

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Article Info
Article ID : 907487
Revision : 3
Created on : 10/17/2007
Published on : 10/17/2007
Exists online : False
Views : 419