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FIX: Memory usage and handle count increase for the Lsass.exe process in Windows Server 2003


View products that this article applies to.

Symptoms

On Microsoft Windows Server 2003-based computers, private byte memory usage and handle count for the Lsass.exe process continually increase. This behavior occurs on computers that are issuing many Kerberos tickets or performing session teardowns. The memory growth eventually leads to virtual memory space exhaustion or virtual address space exhaustion. When space exhaustion occurs, user authentication fails.

Note This memory leak problem only occurs on client-side computers.

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Cause

This problem occurs because the Kerberos task-cleanup routine on Windows Server 2003 computers is susceptible to starvation in high-volume scenarios.

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Resolution

Service Pack Information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003
Note This problem has been fixed in Windows Server 2003 Service Pack 1 (SP1).

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Kerberos.dll5.2.3790.405344,06408-Sep-200518:03x86
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Kerberos.dll5.2.3790.405907,26407-Sep-200514:20IA-64Not Applicable
Wkerberos.dll5.2.3790.405344,06408-Sep-200503:03x86WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Computers that perform many authentication requests, such as high-volume Web servers that are configured to authenticate every HTTP request, are especially vulnerable to this problem. In extreme examples, you may notice an 8- to 10-fold increase in private byte and handle count usage over two hours. We recommend that you install the hotfix package or Windows Server 2003 SP1 on computers that constantly perform authentication session setup and teardown operations. For example, Web servers that perform Kerberos authentication when Web pages are accessed need the hotfix package or Windows Server 2003 SP1.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB907471, kbqfe, kbHotfixServer, kbfix, kbbug, kbautohotfix

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Article Info
Article ID : 907471
Revision : 2
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 230