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Network traffic is interrupted when you hot swap a network adapter in Windows Server 2003 or in Windows XP Professional x64 Edition


View products that this article applies to.

Symptoms

When you hot swap a network adapter or a virtual network adapter, you experience the following symptoms:
  • Any other network adapters that share the same miniport driver in the computer are briefly removed from the system.
  • Because of this first symptom, network traffic is interrupted. Additionally, programs that depend on network traffic may stop working or may generate error messages.
The actual symptoms may vary, depending on the system and programs that are involved.

Note When you remove a device and then install a replacement device of the same model in the same slot while the computer is running, this process is known as hot swapping. The operating system automatically recognizes the replacement device.

When you add Virtual Local Area Networks (VLANS) to network devices, you experience the following symptoms:
  • VLANS on other network devices become disabled.
  • The disabled VLANS show as active in Network Connections.
In this case, network traffic is interrupted.

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Cause

When a network adapter is added or removed, the device driver's HaltHandler function is called for all network adapters, not just for the particular device that is being added or removed. This behavior also occurs when a network adapter is stopped and restarted to enable VLANs.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

Prerequisites

You must be running Windows Server 2003 SP1 to install this hotfix.

Note The x64-based versions of Windows Server 2003 do not require this service pack for you to install this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   31-Aug-2005  03:08  5.2.3790.2520     781,312  Netcfgx.dll      
 
Windows Server 2003, x64-based versions

   Date         Time   Version            Size    File name    Platform
   --------------------------------------------------------------------
   31-Aug-2005  03:41  5.2.3790.2520   1,354,240  Netcfgx.dll      x64
   31-Aug-2005  03:41  5.2.3790.2520     781,312  Wnetcfgx.dll     x86

Windows Server 2003, Itanium-based versions

   Date         Time   Version            Size    File name    Platform
   --------------------------------------------------------------------  
   31-Aug-2005  03:41  5.2.3790.2520   2,104,320  Netcfgx.dll      IA-64
   31-Aug-2005  03:41  5.2.3790.2520     781,312  Wnetcfgx.dll     x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbwinserv2003presp2fix, kbqfe, kbhotfixserver, KB907019

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Article Info
Article ID : 907019
Revision : 8
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 245