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You cannot install a printer that uses a custom print processor in Windows Server 2003 Server or in Windows XP Professional


View products that this article applies to.

Symptoms

When you try to use the Add Printer Wizard to add more printers to a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP Professional, you may receive an error message after the Add Printer Wizard is completed. The error message that you may receive is similar to the following:
Unable to install Printer. The Print Processor does not exist.
Therefore, you cannot add the printer.

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Cause

This problem occurs because the print driver uses a custom print processor.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Windows XP hotfix information

This hotfix may delete all printer IP ports on the computer. You may want to back up the port configuration before you apply this hotfix.

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Updspapi.dll6.2.29.0371,42412-Oct-200523:12x86NoneNot Applicable
Ntprint.dll5.1.2600.304391,13629-Nov-200615:08x86SP2SP2QFE


Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or an x64-based version of Windows Server 2003 installed.

Restart requirement

You must restart the server after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Localspl.dll5.2.3790.2524348,16007-Sep-200502:30x86SP1SP1QFE
Ntprint.dll5.2.3790.252499,84007-Sep-200502:30x86SP1SP1QFE
Updspapi.dll6.1.22.4371,93605-Mar-200501:30x86NoneNot Applicable
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Localspl.dll5.2.3790.2524749,56807-Sep-200515:24x64SP1SP1QFE
Ntprint.dll5.2.3790.2524158,72007-Sep-200515:24x64SP1SP1QFE
Wntprint.dll5.2.3790.252499,84007-Sep-200515:24x86SP1WOW
Updspapi.dll6.1.22.4462,56007-Sep-200515:24x64NoneNot Applicable
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Localspl.dll5.2.3790.2524968,19207-Sep-200515:23IA-64SP1SP1QFE
Ntprint.dll5.2.3790.2524275,45607-Sep-200515:23IA-64SP1SP1QFE
Wntprint.dll5.2.3790.252499,84007-Sep-200515:23x86SP1WOW
Updspapi.dll6.1.22.4639,71207-Sep-200515:23IA-64NoneNot Applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbwinserv2003presp2fix, kbwinxppresp3fix, kbhotfixserver, kbqfe, KB906752

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Article Info
Article ID : 906752
Revision : 11
Created on : 8/29/2007
Published on : 8/29/2007
Exists online : False
Views : 327