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Error message when you try to install or to upgrade a non-native print driver on a Windows Server 2003-based computer: "Access denied"


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003-based computer, when you try to install or to upgrade a non-native print driver, you may encounter the following error message if the file is being used:
Access denied.
For example, this problem can occur when you try to install a driver that is designed for x86-based computers to a computer that is running an x64-based or Itanium-based operating system.

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Cause

This problem occurs because the print driver file is being used. The file may be being used because computers that are based on the non-native architecture may be trying to install the printer which downloads the drivers.

Note Currently, many client workstations are running x86-based operating systems. As servers migrate to x64-based or Itanium-based operating systems, this problem may be seen more frequently.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.2505347,13610-Aug-200517:53x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.2505747,52010-Aug-200503:39x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.2505966,14410-Aug-200503:38IA-64

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Workaround

To work around this problem, follow these steps:
  1. At a command prompt, type the following command, and then press ENTER:
    net stop server
  2. Install or upgrade the driver.
  3. At a command prompt, type the following command, and then press ENTER:
    net start server

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbbug, kbfix, kbqfe, KB905788

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Article Info
Article ID : 905788
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 294