Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A report displays at least one user after you configure the report to display zero users in ISA Server 2004


View products that this article applies to.

Symptoms

In Microsoft Internet Security and Acceleration (ISA) Server 2004, after you configure a report to display zero users, the report still displays at least one user.

This problem applies to the following sections in the report:
  • Top Users in the Summary section
  • Top Web Users in the Web Usage section
  • Top Application Users in the Application Usage section

↑ Back to the top


Cause

This problem occurs because of a bug in the Report Generator component (Sumgen.dll).

↑ Back to the top


Resolution

ISA Server 2004, Standard Edition

Service pack information

To resolve this problem, obtain the latest service pack for Internet Security and Acceleration Server 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
891024� How to obtain the latest ISA Server 2004 service pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have ISA Server 2004 Service Pack 1 (SP1) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
891024� How to obtain the latest ISA Server 2004 service pack
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   -----------------------------------------------------
   10-Aug-2005  13:39  4.0.2163.280  485,328  Sumgen.dll

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Internet Security and Acceleration Server 2004 Service Pack 2.

↑ Back to the top


More information

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
For more information about how to install ISA Server 2004 hotfixes and updates, click the following article number to view the article in the Microsoft Knowledge Base:
885957� How to install ISA Server hotfixes and updates

↑ Back to the top


Keywords: KB905655, kbhotfixserver, kbpubtypekc, kbqfe, kbautohotfix

↑ Back to the top

Article Info
Article ID : 905655
Revision : 11
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 351