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FIX: SNA Manager may incorrectly display a status of Status Pending or Status Undetected for some Host Integration Server 2004 computers or Host Integration Server 2004 computers in a Host Integration Server subdomain


View products that this article applies to.

Symptoms

Computers in a Microsoft Host Integration Server subdomain are running Host Integration Server 2004 or Host Integration Server 2000. The computers are active, and the computers provide resources to Host Integration Server clients and Host Integration Server applications.

However, SNA Manager may display one of the following status types for one or more of the computers:
Status Pending
Status Undetected

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Cause

This problem occurs because the Host Integration Server management components do not recover from network outages between Host Integration Server computers in certain cases. When this behavior occurs, the SNA Manage Client process (Mngcli.exe) cannot receive status notifications. Therefore, SNA Manager displays an incorrect status for the Host Integration Server computer.

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Resolution

Host Integration Server 2000

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Fmistr32.dll5.0.0.208120,75204-Nov-200520:47x86
Mmcsna.dll5.0.0.2081229,64804-Nov-200520:48x86
Mngbase.dll5.0.0.2081139,53604-Nov-200520:48x86
Mngcli.exe5.0.0.2081102,67204-Nov-200520:48x86
Mngext.dll5.0.0.208128,94404-Nov-200520:48x86
Mngsna.dll5.0.0.2081114,96004-Nov-200520:48x86
Nthstreg.dll5.0.0.208128,94404-Nov-200520:48x86
Sec400.dll5.0.0.208153,52004-Nov-200520:48x86
Sechost.dll5.0.0.208153,52004-Nov-200520:48x86
Sfmngext.dll5.0.0.208120,75204-Nov-200520:48x86
Snaadmin.dll5.0.0.2081401,68004-Nov-200520:48x86
Snabase.exe5.0.0.2081282,89604-Nov-200520:47x86
Snacfg.dll5.0.0.2081209,16804-Nov-200520:48x86
Snadmod.dll5.0.0.2081557,32804-Nov-200520:47x86
Snaevent.dll5.0.0.2081483,60004-Nov-200520:47x86
Snahsmsg.dll5.0.0.208178,09604-Nov-200520:48x86
Snaip.dll5.0.0.208182,19204-Nov-200520:47x86
Snamanag.dll5.0.0.2081143,63204-Nov-200520:48x86
Snancp.dll5.0.0.208120,75204-Nov-200520:47x86
Snanw.dll5.0.0.208165,80804-Nov-200520:47x86
Snaole.dll5.0.0.2081565,52004-Nov-200520:48x86
Snaolewmi.dll5.0.0.2081553,23204-Nov-200520:48x86
Snapage.dll5.0.0.2081512,27204-Nov-200520:48x86
Snarpc.dll5.0.0.2081151,82404-Nov-200520:48x86
Snatrc.dll5.0.0.208198,57604-Nov-200520:47x86
Snatrccn.dll5.0.0.208141,23204-Nov-200520:47x86
Snatrcsn.dll5.0.0.208169,90404-Nov-200520:47x86
T3mngext.dll5.0.0.208145,32804-Nov-200520:48x86
T5mngext.dll5.0.0.208145,32804-Nov-200520:48x86
Vstapi.dll5.0.0.208116,65604-Nov-200520:47x86
Wmisna.dll5.0.0.2081463,12004-Nov-200520:48x86
Wmisnastatus.dll5.0.0.208186,28804-Nov-200520:48x86
Wmisnatrace.dll5.0.0.2081164,11204-Nov-200520:48x86

Host Integration Server 2004

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Fmistr32.dll6.0.1996.08,19207-Nov-200522:39x86
Mmcsna.dll6.0.1996.0252,41607-Nov-200522:42x86
Mngagent.exe6.0.1996.084,99207-Nov-200522:41x86
Mngcli.exe6.0.1996.084,48007-Nov-200522:41x86
Mngext.dll6.0.1996.014,84807-Nov-200522:41x86
Mngsna.dll6.0.1996.095,74407-Nov-200522:41x86
Nthstreg.dll6.0.1996.036,86407-Nov-200522:41x86
Sec400.dll6.0.1996.039,42407-Nov-200522:41x86
Sechost.dll6.0.1996.039,42407-Nov-200522:41x86
Sfmngext.dll6.0.1996.08,19207-Nov-200522:42x86
Snaadmin.dll6.0.1996.0302,59207-Nov-200522:42x86
Snabase.exe6.0.1996.0215,04007-Nov-200522:39x86
Snacfg.dll6.0.1996.0167,93607-Nov-200522:41x86
Snadmod.dll6.0.1996.0649,21607-Nov-200522:39x86
Snaevent.dll6.0.1996.0471,55207-Nov-200522:39x86
Snahsmsg.dll6.0.1996.088,06407-Nov-200522:41x86
Snaip.dll6.0.1996.098,81607-Nov-200522:39x86
Snamanag.dll6.0.1996.0157,18407-Nov-200522:41x86
Snancp.dll6.0.1996.010,24007-Nov-200522:39x86
Snanw.dll6.0.1996.069,63207-Nov-200522:39x86
Snatrc.dll6.0.1996.057,34407-Nov-200522:39x86
Snatrccn.dll6.0.1996.022,01607-Nov-200522:39x86
Snatrcsn.dll6.0.1996.045,05607-Nov-200522:39x86
T3mngext.dll6.0.1996.030,72007-Nov-200522:42x86
T5mngext.dll6.0.1996.030,72007-Nov-200522:42x86

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Workaround

To work around this problem, stop and then restart the SNA MngAgent service on the Host Integration Server computer that is running SNA Manager. When you do this, SNA Manager displays the correct status for Host Integration Server computers. To restart the SNA MngAgent service, follow these steps:
1.Click Start, click Run, type services.msc, and then click OK.
2.Right-click SNA MngAgent, and then click Restart.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB905604, kbhotfixserver, kbqfe, kbfix, kbpubtypekc

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Article Info
Article ID : 905604
Revision : 2
Created on : 9/11/2007
Published on : 9/11/2007
Exists online : False
Views : 442