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You cannot access a URL from an Outlook Web Access-based e-mail message when the URL contains DBCS characters


View products that this article applies to.

Symptoms

Consider the following scenario. You are running Microsoft Outlook Web Access on a server that is running Microsoft Exchange Server 2003 Service Pack 1 (SP1) or Exchange Server 2003 Service Pack 2 (SP2). Additionally, this server has the hotfix that is mentioned in the following Microsoft Knowledge Base (KB) article is installed on the Microsoft Exchange server:
890059 URL that contains DBCS characters may be corrupted in an e-mail in OWA
In Outlook Web Access, you click a URL that is in the body of an e-mail message. Additionally, the following conditions are true:
  • The e-mail message is formatted as either HTML or Rich Text Format (RTF).
  • The URL contains Traditional Chinese, Simplified Chinese, Japanese, or Korean characters. These characters are also known as double-byte character set (DBCS) characters.
  • The URL does not start with the fully qualified domain name (FQDN) of the destination server.
In this scenario, you cannot access the URL if the URL does not contain the FQDN of the destination server.

In the following example, the URL points to a server that is named Server1. Additionally, Server1 is in a domain that is named Domain1.com.
http://server1.domain.com
You cannot access the URL in Outlook Web Access if the URL is entered in a different format from the format that appears in this example. For example, you cannot access this URL if it has the following format:
http://server1

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Cause

This problem occurs because Microsoft Exchange Server 2003 unnecessarily converts the DBCS characters in the URL to UTF-8 characters. This conversion occurs when Outlook Web Access retrieves the HTML e-mail message from the Microsoft Exchange information store. Because of this conversion, the URL becomes corrupted.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Exchange Server 2003 Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the Microsoft Exchange Information Store service and all its dependent services are automatically stopped and then restarted when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Microsoft Exchange Server 2003 SP1
File nameFile versionFile sizeDateTimePlatform
Mdbmsg.dll6.5.7233.613,270,14403-Dec-200504:57x86
Redir.aspNot Applicable3,30404-Jun-200501:56Not Applicable
Store.exe6.5.7233.615,200,89603-Dec-200505:31x86
Microsoft Exchange Server 2003 SP2
File nameFile versionFile sizeDateTimePlatform
Mdbmsg.dll6.5.7651.23 3,361,280 23-Mar-2006 12:21x86
Redir.aspNot Applicable3,307 23-Mar-2005 12:20Not Applicable
Store.exe6.5.7651.23 5,257,72805-Jul-2006 03:08x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

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Keywords: KB905204, kbbug, kbfix, kbhotfixserver, kbqfe, kbautohotfix, kbarchive, kbnosurvey

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Article Info
Article ID : 905204
Revision : 5
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 313