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FIX: The logon prompt and the data that you type in response to any shell script does not echo when you run Windows Services for UNIX 3.5 on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

When you try to dial into a remote computer that is running Microsoft Windows Services for UNIX 3.5, the logon prompt does not echo back the characters that you type. Additionally, the data that you type in response to any shell script does not echo. You experience this problem when you run Windows Services for UNIX 3.5 on a Microsoft Windows Server 2003-based computer.

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Cause

This problem occurs after you install the hotfix that is described in Microsoft Knowledge Base article 889087. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889087� FIX: The select( ) function and the write( ) function do not handle the non-blocking serial I/O correctly

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Resolution

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must be running Windows Services for UNIX 3.5.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Posix.exe8.0.1969.35130,04826-Jul-200503:26x86
Psxdll.dll8.0.1969.35345,08826-Jul-200503:26x86
Psxrun.exe8.0.1969.35104,44826-Jul-200503:26x86
Psxss.exe8.0.1969.35765,44026-Jul-200503:26x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbhotfixserver, kbqfe, kbpubtypekc, KB904781

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Article Info
Article ID : 904781
Revision : 6
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 313