Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Applications that use disk quota API functions may stop responding on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

Applications that use disk quota API functions may stop responding on a Microsoft Windows Server 2003-based computer.

Note Symptoms from this problem may vary in different applications.

↑ Back to the top


Cause

This problem occurs because of an incorrect message pump method. When an application sends a message to the disk quota, the message stays in the message queue at first. In some circumstances, when the disk quota monitors the message queue, the disk quota is only aware of the messages that are newly added to the message queue. The disk quota may ignore the messages that already exist in the message queue. Then, the application may continue to wait for responses from the disk quota.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dskquota.dll5.2.3790.37087,04014-Jul-200514:58x86NoneRTMQFE
Dskquota.dll5.2.3790.248793,18414-Jul-200515:03x86SP1SP1QFE
Arpidfix.exe5.2.3790.248732,25614-Jul-200501:05x86NoneNot Applicable
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dskquota.dll5.2.3790.370262,65614-Jul-200500:22IA-64NoneRTMQFE
Wdskquota.dll5.2.3790.37087,04014-Jul-200500:22x86NoneWOW
Dskquota.dll5.2.3790.2487282,62414-Jul-200500:22IA-64SP1SP1QFE
Wdskquota.dll5.2.3790.248793,18414-Jul-200500:22x86SP1WOW
Arpidfix.exe5.2.3790.248774,75214-Jul-200500:22IA-64NoneNot Applicable
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dskquota.dll5.2.3790.2487151,55214-Jul-200500:22x64SP1SP1QFE
Wdskquota.dll5.2.3790.248793,18414-Jul-200500:22x86SP1WOW
Arpidfix.exe5.2.3790.248743,00814-Jul-200500:22x64NoneNot Applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

This hotfix corrects the problematic message pump method. After you install the hotfix, the disk quota process all the messages in the messaging queue. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbwinserv2003sp2fix, kbwinserv2003presp2fix, kbexpertiseinter, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB904249

↑ Back to the top

Article Info
Article ID : 904249
Revision : 7
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 312