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After you publish a certificate in Active Directory on a Windows XP-based computer, certificate renewal may leave the Active Directory certificate store empty


View products that this article applies to.

Symptoms

You are trying to use the autoenrollment feature to manage the life cycle of a user's certification authority certificate on a Microsoft Windows XP-based computer. After you publish the certificate in Active Directory directory service, certificate renewal may leave the Active Directory certificate store empty.

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Cause

This problem occurs when the autoenrollment feature removes the old certificate from Active Directory without publishing a new certificate. This problem occurs when you renew the certificate under some specific circumstances.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows XP Service Pack 1 (SP1) or Windows XP Service Pack 2 (SP2) installed before you install this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Pautoenr.dll5.1.2600.172258,88029-Jul-200521:03x86
Windows XP with Service Pack 2
File nameFile versionFile sizeDateTimePlatform
Pautoenr.dll5.1.2600.272862,97629-Jul-200520:55x86

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Workaround

To work around this problem, retrieve the certificate from the certification authority (CA), and then publish the certificate in Active Directory.

For more information about how to retrieve a certificate from a Microsoft Windows Server 2003 CA, visit the following Microsoft Web site:For more information about how to retrieve a certificate from a Microsoft Windows 2000 CA, visit the following Microsoft Web site:For more information about how to publish a certificate in Active Directory on a Windows Server 2003-based computer, visit the following Microsoft Web sites:For more information about how to publish a certificate in Active Directory on a Windows 2000-based computer, visit the following Microsoft Web site:

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about certificate autoenrollment in Windows XP, visit the following Microsoft Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinxpsp2fix, kbwinxppresp2fix, kbfix, kbbug, kbhotfixserver, kbqfe, KB903930

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Article Info
Article ID : 903930
Revision : 5
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 1201