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The Cluster Administrator console may stop responding when it enumerates resources on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

When you try to use the Cluster Administrator console on a Microsoft Windows Server 2003-based computer, the console may not finish its startup. Additionally, you may experience the following symptoms:
  • The console stops responding when it enumerates resources in the status bar at the bottom of the user interface.
  • If you use cluster commands at a command prompt to administer a server cluster, the cluster commands do not respond.
Note
  • At least one instance of the Microsoft Distributed Transaction Coordinator (MS DTC) service is affected by this problem.
  • The cluster remains in a functional state, but cannot be managed, even by using the Cluster.exe tool.

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Cause

This problem occurs because a remote procedure call (RPC) unlock process cannot be completed correctly in Windows Server 2003.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit versions
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File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.2.3790.2501,191,93614-Jan-200508:57x86
Rpcproxy.dll5.2.3790.14126,11216-Mar-200403:17x86
Rpcrt4.dll5.2.3790.394659,96823-Aug-200503:28x86
Rpcss.dll5.2.3790.250294,91214-Jan-200508:57x86
Windows Server 2003 with SP1, 32-bit versions
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File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.2.3790.2514642,04823-Aug-200503:38x86
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformService branch
Rpcrt4.dll5.2.3790.25141,714,17622-Aug-200512:50x64Not Applicable
Wrpcrt4.dll5.2.3790.2514625,66422-Aug-200512:50x86WOW
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformService branch
Ole32.dll5.2.3790.2503,576,83223-Aug-200506:10IA-64Not Applicable
Rpcproxy.dll5.2.3790.14173,21623-Aug-200506:10IA-64Not Applicable
Rpcrt4.dll5.2.3790.3942,151,42423-Aug-200506:10IA-64Not Applicable
Rpcss.dll5.2.3790.250688,64023-Aug-200506:10IA-64Not Applicable
Wole32.dll5.2.3790.2501,191,93623-Aug-200506:14x86WOW
Wrpcproxy.dll5.2.3790.14126,11223-Aug-200506:14x86WOW
Wrpcrt4.dll5.2.3790.394544,76823-Aug-200506:14x86WOW
Windows Server 2003 with SP1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rpcrt4.dll5.2.3790.25142,458,11223-Aug-200506:14IA-64SP1Not Applicable
Wrpcrt4.dll5.2.3790.2514625,66423-Aug-200506:14x86SP1WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

Locking mechanisms are implemented by using single-writer, multi-reader (SWMR) locks. When an SWMR lock is unlocked, it does not synchronize correctly. Therefore, all RPC threads in a process must wait for this lock, and the process cannot be recovered. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, KB903929

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Article Info
Article ID : 903929
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 301