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A Windows 2000-based, Windows Server 2003-based, or Windows XP-based computer that was set up by using a Windows 2000, Windows Server 2003, or Windows XP image does not appear in the WSUS console


View products that this article applies to.

Symptoms

A computer that is running Windows 2000, Windows Server 2003, or Windows XP does not appear in the Windows Server Update Services (WSUS) console.

This issue occurs if the computer was set up by using a Windows 2000 image, a Windows Server 2003 image, or a Windows XP image in which the registry value for SusClientID is populated before it is deployed to client computers.

When you use Sysprep to generalize an image for a virtual machine, or when you use a unique SID-generating technology to create the images, the SusClientId registry value is not cleared if it is populated within the image before the image is deployed.

Note In WSUS 3.0, the client changes its SusClientID if the hardware configuration changes. For Windows Vista, for Windows Server 2008, and for later versions, Sysprep is changed to reset the SusClientID. Therefore, this problem affects only virtual machines that run pre-Windows Vista operating systems, or that were not created by using Sysprep.

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Cause

This issue occurs because the imaged clients may have a duplicate SusClientID value in the registry.

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Resolution

To resolve this issue, use one of the following methods.

Method 1: Change the Registry

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Click Start, click Run, type cmd in the Open box, and then click OK.
  2. At the command prompt, type net stop wuauserv, and then press ENTER.
  3. Click Start, click Run, type regedit in the Open box, and then click OK.
  4. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate
  5. In the details pane of Registry Editor, delete the following registry entries:
    • PingID
    • AccountDomainSid
    • SusClientId
    • SusClientIDValidation
    Note Windows Update Agent 3.0 adds the SusClientIDValidation value. This value was released in May 2007. The other registry entries exist in both Windows Update Agent 2.0 and in Windows Update Agent 3.0.
  6. Exit Registry Editor.
  7. At the command prompt, type net start wuauserv, and then press ENTER.
  8. At the command prompt, type wuauclt.exe /resetauthorization /detectnow, and then press ENTER.
  9. Wait 10 minutes for a detection cycle to finish.
  10. Start the WSUS console to make sure that the clients appear in the WSUS console.

Method 2: Use the Sysprep.inf file

If you already have a file that is named Sysprep.inf in the same folder as Sysprep.exe, follow these steps.

Note To resolve this problem, these steps must be applied before you generalize the image.
  1. Double-click Sysprep.inf to open the file in Notepad.
  2. Scroll down to find the [GuiRunOnce] section.

    Note If a [GuiRunOnce] section does not exist, create it by typing it at the end of Sysprep.inf file.
  3. Underneath [GuiRunOnce], type the following text.

    Note These new commands are listed as "Command0" through "Command3." These designations are correct only if the [GuiRunOnce] section currently contains no commands. If there are already commands underneath [GuiRunOnce], change the �Commandx� entries in the new commands so that they begin with the next sequential number. For example, if the section already contains five commands that are listed as "Command0" through "Command4," number these new commands as "Command5" through "Command8."
    • Command0=�reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f�
    • Command1=�reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f�
    • Command2=�reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f�
    • Command3=�reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f�
  4. On the File menu, click Save.
  5. On the File menu, click Exit.

Method 3: Create a Sysprep.inf file if you do not have the file

If you do not have a file that is named Sysprep.inf in the same folder as Sysprep.exe, follow these steps to create the file.

Note To resolve this problem, these steps must be applied before you generalize the image.
  1. Click Start, point to All Programs, click Accessories, and then click Notepad.
  2. Type the following text:
    [GuiRunOnce]

    Command0=�reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v PingID /f�

    Command1=�reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v AccountDomainSid /f�

    Command2=�reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /f�

    Command3=�reg.exe delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIDValidation /f�
  3. On the File menu, click Save.
  4. Locate the directory in which the Sysprep.exe file is located.
  5. Type Sysprep.inf in the File name box.
  6. Select All Files in the Save as type box.
  7. Click Save.
  8. On the File menu, click Exit.

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More information

The first Windows 2000-based computer, Windows Server 2003-based computer, or Windows XP-based computer that was set up by using a Windows 2000 image, a Windows Server 2003 image, or a Windows XP image appears in the WSUS console. However, the next Windows 2000-based, Windows Server 2003-based, or Windows XP-based computers that are set up by using the same image do not appear. This issue occurs because the first computer that was set up by using one of these images is using the same SusClientID value.

After you follow the steps that are described in the "Resolution" section, a new SusClientID value is created. Additionally, the next Windows 2000-based computers, Windows Server 2003-based computers, or Windows XP-based computers that are set up by using the same image appear in the WSUS console.

We have added an automatic feature to the Windows Update Agent that is installed on WSUS client computers. This feature can help address this duplicate-SusClientID issue. The feature provides a solution that is added to the client-side Windows Update Agent starting with version 7.0.6000.374. (This version is the client version that was included with WSUS 3.0.)

This solution uses a hardware validation routine to determine whether the current client hardware has changed since the SUSClientID value was created. (This hardware includes network adapters and hard disks.)

The hardware validation routine is stored as a binary large object in the Susclientidvalidation registry key at the same location as the Susclientid registry value. If the hardware validation routine indicates that all the hardware has changed, a new SusClientID value is generated by the client.

Note The hardware validation routine requires that the client connect to a server that is running Windows Software Update Services 3.0 or a later version of WSUS and not to a server that is running Windows Software Update Services 2.0.

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Keywords: kbdeployment, kbtshoot, kbprb, KB903262

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Article Info
Article ID : 903262
Revision : 6
Created on : 5/21/2009
Published on : 5/21/2009
Exists online : False
Views : 761