Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You may receive a "You cannot undo line [LineNumber]" error message when you try to undo a warehouse shipment in Microsoft Dynamics NAV


View products that this article applies to.

SYMPTOMS

When you try to undo a warehouse shipment in Microsoft Dynamics NAV or in Microsoft Business Solutions - Navision, you may receive the following error message:

You cannot undo line LineNumber , if Warehouse Shipment lines have been posted.

 

Microsoft Business Solutions-Navision 4.0 and Microsoft Navision 4.0 are now part of Microsoft Dynamics NAV 4.0. All references to Microsoft Business Solutions-Navision or to Microsoft Navision 4.0 pertain to Microsoft Dynamics NAV.

↑ Back to the top


CAUSE

This problem occurs because the undo functionality is not available after the purchase order or the sales order has been invoiced. If the system is set up to use Warehouse Pick and Warehouse Shipment, you will receive the error message when you try to undo the shipment, even if the purchase order or the sales order has not been invoiced.

↑ Back to the top


RESOLUTION

To resolve this problem in Microsoft Dynamics NAV, you can delete the registered pick lines and the posted warehouse shipment. You can then use the Undo Shipment function in the Sales & Marketing window. To do this, follow these steps:
1. Click Warehouse , click History , click Registered Documents , and then click Registered Picks .
2. In the Registered Pick window, press F5.
3. In the Registered Whse. Pick List window, click the pick that is registered with the warehouse shipment that you want to undo, and then click OK .
4. Press F4, and then click Yes when you receive the following message:

Delete Registered Whse. Activity Hdr.?

The registered pick is deleted.
5. Click Warehouse , click History , click Posted Documents , and then click Posted Shipments .
6. In the Posted Whse. Shipment window, press F5
7. In the Posted Whse. Shipment List window, click the warehouse shipment that you want to undo, and then click OK .
8. Press F4, and then click Yes when you receive the following message:

Delete Posted Whse. Shipment Header?

The warehouse shipment is deleted.
9. Click Sales & Marketing , click History , and then click Posted Shipments .
10. In the Posted Sales Shipment window, press F5.
11. In the Posted Sales Shipment List window, click the shipment that you want to undo, and then click OK .
12. Click Functions , click Undo Shipment , and then click Yes when you receive the following message:

Do you really want to undo the selected Shipment lines?

The shipment quantity shows a negative quantity amount.

↑ Back to the top


MORE INFORMATION

Steps to reproduce the problem in Microsoft Dynamics NAV

1. Create and post a warehouse shipment:
a. In the Main Menu window, click Sales & Marketing , expand Order Processing , and then click Orders .
b.

In the Sales Header, enter the following information:

Sell-to Customer No. : 10000
Posting Date : 05/26/05
Order Date : 05/26/05

c.

In the grid, create two records by entering the following information:

Type : Item
No. : LS-100
Location : WHITE
Quantity : 1
Unit of Measure Code : PCS
Type : Item
No. : LS-10PC
Location : WHITE
Quantity : 1
Unit of Measure Code : BOX


  •  
d. Click Functions , and then click Release Document .
e. Click Functions , click Create Whse. Shipment .
f. In the Warehouse Shipment window, click Functions , and then click Create Pick .
g. In the Create Pick window, leave all defaults, and then click OK .
h. In the Warehouse Shipment window, click Posting , click Post Shipment , click Ship , and then click OK .
i. In the Main Menu window, click Warehouse , expand Goods Handling Multiple Orders , and then click Picks .
j. In the Warehouse Pick window, press F5.
k. In the Warehouse Pick List window, click the pick that you created in step 1g, and then click OK .
l. Click Registering , and then click Register Pick .

Note You may receive the following message:

Nothing to register.

The message means the Qty. to Handle field in the Pick window is blank. The program requires that the field be populated with the value that appears in the Quantity field.
m. Return to the warehouse shipment that you just created.
n. In the Warehouse Shipment window, click Posting , click Post Shipment , click Ship , and then click OK .
2. Try to undo the warehouse shipment that you created in step 1:
a. In the Main Menu window, click Sales & Marketing , expand History , and then click Posted Shipments .
b. In the Posted Sales Shipment window, press F5, click the sales shipment that you posted in step 1, and then click OK .
c. Click Functions , click Undo Shipment .

You may receive the following error message:


You cannot undo line LineNumber , if Warehouse Shipment lines have been posted.

Note The steps to reproduce the problem in Microsoft Business Solutions - Navision 3.60 and 3.70 are different from the steps for Microsoft Dynamics NAV.

 

Query Words:  

Warehouse Management delete

 

↑ Back to the top


APPLIES TO:

Microsoft Dynamics NAV 5.0
Microsoft Dynamics NAV 4.0
Microsoft Business Solutions–Navision 3.70
Navision Attain 3.6

↑ Back to the top


Keywords: kbprb, kberrmsg, kbtshoot, kbMBSPartner, kbMBSMigrate, kbMBSnav5, kbFreshness2007, BemisKB903193, kbnosurvey, kb, kbMBSWarehousemanagement

↑ Back to the top

Article Info
Article ID : 903193
Revision : 4
Created on : 4/6/2017
Published on : 4/6/2017
Exists online : False
Views : 637