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An access violation occurs and a program closes when you move the pointer over a file name in the Open, Save, or "Save As" dialog box on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003-based computer that has Adobe Reader 7.0 installed, you move the pointer over a file name in the Open dialog box, in the Save dialog box, or in the Save As dialog box. After you do this, the program abruptly closes.

Note For more information about how to reproduce this problem, see the "More Information" section.

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Cause

This problem occurs because Windows tries to reference the pointer of the shell column provider without loading the shell column provider file (Pdfshell.dll).

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit versions with Service Pack 1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Shell32.dll6.0.3790.25808,379,90401-Dec-200517:53x86SP1
W03a2409.dll5.2.3790.258016,38401-Dec-200502:38x86SP1

Windows Server 2003, Itanium-based versions with Service Pack 1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.3790.258013,246,46401-Dec-200502:11IA-64SP1Not Applicable
W03a2409.dll5.2.3790.258015,36001-Dec-200502:11IA-64SP1Not Applicable
Wshell32.dll6.0.3790.25808,379,90401-Dec-200502:11x86SP1WOW
Ww03a2409.dll5.2.3790.258016,38401-Dec-200502:11x86SP1WOW

Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.3790.258010,492,41601-Dec-200502:11x64SP1Not Applicable
W03a2409.dll5.2.3790.258016,89601-Dec-200502:11x64SP1Not Applicable
Wshell32.dll6.0.3790.25808,379,90401-Dec-200502:11x86No requirementWOW
Ww03a2409.dll5.2.3790.258016,38401-Dec-200502:11x86No requirementWOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

Steps to reproduce this problem

  1. In Notepad, click File, and then click Open, Save, or Save As.
  2. Click Desktop.
  3. Move the pointer over a file name. When the ToolTip appears, click Cancel to close the dialog box.
  4. Click File, and then click Open, Save, or Save As.
  5. Move the pointer over the same file name that you moved the mouse pointer over in step 4.
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates
909486� A program closes when you move the mouse pointer over the program file in the Open, Save, or Save As dialog box on a Windows XP Service Pack 2-based computer

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbbug, kbfix, kbHotfixServer, kbqfe, KB903154

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Article Info
Article ID : 903154
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 220