Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: An Office 2003 application stops responding for 10 to 15 seconds when you save a document that contains paths to resources that do not exist on the network on a computer that is running Windows Server 2003


View products that this article applies to.

Symptoms

When you save a document in Microsoft Office 2003 on a computer that is running Microsoft Windows Server 2003, the Office 2003 application stops responding for 10 to 15 seconds. This behavior occurs when the saved document contains hyperlinks or Universal Naming Convention (UNC) paths to resources that do not exist on the network.

Note This problem does not affect performance when you access resources over the network, such as file copy operations.

↑ Back to the top


Cause

This problem occurs because name resolution fails and time-outs occur.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix rollup package information

This problem is fixed in the Microsoft COM+ 1.5 hotfix rollup package 7. For more information about the rollup package, click the following article number to view the article in the Microsoft Knowledge Base:
910730 Availability of Windows Server 2003 Post-Service Pack 1 COM+ 1.5 Hotfix Rollup Package 7

Hotfix information

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.2.3790.25721,247,23217-Nov-200503:20
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.2.3790.4451,193,98417-Nov-200503:09
Windows Server 2003, Itanium-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.2.3790.25723,999,74416-Nov-200518:45IA-64
Wole32.dll5.2.3790.25721,247,23216-Nov-200518:45
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.2.3790.4453,582,97616-Nov-200518:45IA-64
Wole32.dll5.2.3790.4451,193,98416-Nov-200518:45
Windows Server 2003, x64-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Ole32.dll5.2.3790.25722,546,68816-Nov-200518:45x64
Wole32.dll5.2.3790.25721,247,23216-Nov-200518:45x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

If you monitor network traffic when you try to save the Office 2003 file, you can see name resolution requests to the server resources that are used in the hyperlinks and the UNC paths that are in the document. You can also see that these names cannot be resolved successfully.

By attaching Logger.exe from the Debugging Tools for Windows to the Office 2003 application, you can see a delay in the GetLongPathNameW function calls.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
260943 Slow performance accessing files may slow Office programs
For more information about the Debugging Tools for Windows, visit the following Microsoft Web site:

↑ Back to the top


Keywords: kbwinserv2003sp2fix, kbhotfixrollup, kbqfe, kbbug, kbfix, KB903087

↑ Back to the top

Article Info
Article ID : 903087
Revision : 7
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 347