Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A disk management program may stop responding when you use the program to expand a logical unit number size on a computer that is running Windows Server 2003 Service Pack 1


View products that this article applies to.

Symptoms

Consider the following scenario:
  • The computer is running Microsoft Windows Server 2003 Service Pack 1 (SP1).
  • You use a disk management program to expand a logical unit number (LUN) size.
The disk management program may stop responding.

↑ Back to the top


Cause

This problem occurs if the following conditions are true:
  • The LUN size changes without sending UNIT ATTENTION code.
  • The disk management program sends IOCTL_DISK_UPDATE_DRIVE_SIZE disk I/O control code to update the logical unit number (LUN) size.
If these conditions are true, the call to read the drive capacity for this disk I/O control code causes the disk management program to stop responding. This problem occurs because of the partitioning lock type that the disk class driver uses.

↑ Back to the top


Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003 SP1, 32-bit versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Jun-2005  02:04  5.2.3790.2473      54,784  Classpnp.sys
Windows Server 2003, x64-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Jun-2005  04:55  5.2.3790.2473      97,792  Classpnp.sys
Windows Server 2003 SP1, Itanium-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Jun-2005  04:55  5.2.3790.2473     160,768  Classpnp.sys
Windows Server 2003, x86-based versions
   Date         Time   Version            Size    File name   CPU    Folder
   --------------------------------------------------------------
   24-Jun-2005  01:14  5.2.3790.356      61,952  Classpnp.sys      x86      RTMQFE
   Date         Time   Version            Size    File name   CPU    Folder
   --------------------------------------------------------------
   24-Jun-2005  02:04   5.2.3790.2473       54,784  Classpnp.sys      x86       SP1QFE
Windows Server 2003 and Windows XP, x64-based versions
   Date         Time   Version            Size    File name   CPU    Folder
   --------------------------------------------------------------
   24-Jun-2005  01:14  5.2.3790.356      61,952  Classpnp.sys      x86      RTMQFE
Windows Server 2003, Itanium-based versions
   Date         Time   Version            Size    File name   CPU    Folder
   --------------------------------------------------------------
   24-Jun-2005  04:55  5.2.3790.356      146,432  Classpnp.sys      IA-64      RTMQFE
   Date         Time   Version            Size    File name   CPU    Folder
   --------------------------------------------------------------
   24-Jun-2005  04:55  5.2.3790.2473      160,768  Classpnp.sys      IA-64      SP1QFE

↑ Back to the top


Workaround

Program developers can work around this problem by using IOCTL_DISK_UPDATE_PROPERTIES disk I/O control code instead of using IOCTL_DISK_UPDATE_DRIVE_SIZE disk I/O control code to update the disk size.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

↑ Back to the top


More information

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbwinserv2003sp2fix, kbbug, kbfix, kbqfe, kbhotfixserver, KB902837

↑ Back to the top

Article Info
Article ID : 902837
Revision : 3
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 341