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FIX: Error messages when you use a Windows Management Instrumentation (WMI) query to register WMI events on a computer that is running Windows Server 2003 or Windows XP: "0x80041032" and "0x80041003"


View products that this article applies to.

Symptoms

You use a Microsoft Windows Management Instrumentation (WMI) query that contains the LIKE operator to register WMI events on a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP. When you do this, the event registration fails. Additionally, you may receive the following error messages:

Error message 1
Number: 0x80041032
Facility: WMI

Description: Call cancelled
Note In this error message, the word "cancelled" is a misspelling for the word "canceled."

Error message 2
Number: 0x80041003
Facility: WMI

Description: Access denied

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Cause

This problem occurs because the Windows NT Event Log provider cannot parse a WMI Query Language (WQL) event registration query that contains the LIKE operator.

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Resolution

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

Prerequisites
To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003 SP1, x86-based versions

File nameFile versionFile sizeDateTimePlatform
Ntevt.dll5.2.3790.2466235,52016-Jun-200515:53x86
Windows Server 2003 SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ntevt.dll5.2.3790.2466708,09616-Jun-200501:14IA-64
Windows Server 2003 SP1, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ntevt.dll5.2.3790.2466359,42416-Jun-200501:14x64

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Windows XP

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows XP Service Pack 1 (SP1) or Windows XP Service Pack 2 (SP2) installed on the computer.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP SP1, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ntevt.dll5.2.3790.2466359,42416-Jun-200501:14x64
Windows XP SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ntevt.dll5.1.2600.2699212,48016-Jun-200515:18x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbhotfixserver, kbqfe, qfekb, kbbug, kbfix, kbwinserv2003presp1fix, kbpubtypekc, kb

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Article Info
Article ID : 902346
Revision : 4
Created on : 9/29/2020
Published on : 9/29/2020
Exists online : False
Views : 276