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A device may not establish a connection with a desktop computer when you try to connect the device to the desktop computer through an external USB port hub in Windows XP or in Windows Server 2003


View products that this article applies to.

Problem description

When you try to connect a device to a desktop computer that is running Microsoft Windows XP or Microsoft Windows Server 2003, the device may not establish a connection with the desktop computer. This problem occurs when you try to connect the device to the desktop computer through an external USB port hub.

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Resolution

To fix this problem, use one or more of the following methods.

Method 1

In Device Manager, scan for hardware changes. To do this, follow these steps:
  1. Start Device Manager.
  2. On the Action menu, click Scan for hardware changes.
Now go to the "Did this fix the problem?" section.


Method 2

Shut down and then restart the computer.

Now go to the "Did this fix the problem?" section.


Method 3


To have us fix this problem for you, go to the "Fix it for me" section. If you would rather fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem automatically, click the Fix this problem link. Click Run in the File Download dialog box, and then follow the steps in this wizard.





Note this wizard may be in English only; however, the automatic fix also works for other language versions of Windows.



Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or a CD, and then run it on the computer that has the problem.

Now go to the "Did this fix the problem?" section.


Let me fix it myself

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

Disable the Selective Suspend feature of the USB hub driver. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\USB
  3. On the Edit menu, point to New, and then click DWORD.
  4. Type DisableSelectiveSuspend, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type 1, and then click OK.
Note If the DisableSelectiveSuspend registry subkey is not present, you must create this registry subkey. This setting affects all USB host controller drivers in the system.

If the DisableSelectiveSuspend value is set to 1, the Selective Suspend feature is disabled. Additionally, the Allow the computer to turn off this device to save power check box does not appear on the Power Management tab for the USB Root Hub.

Now go to the "Did this fix the problem?" section.


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Did this fix the problem?

Check whether the problem is fixed. If the problem is fixed, you are finished with this article. If the problem is not fixed, you can contact support.

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Cause

This problem occurs because of a race condition in the Selective Suspend feature of the USB hub driver. The Selective Suspend feature is designed to suspend the USB hub to efficiently maintain battery power. However, the Selective Suspend feature sometimes may not correctly wake up the USB hub.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

817900 USB port may stop working after removing or inserting USB device

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Keywords: kb, kbmsifixme, kbfixme, kbentirenet, kbtshoot, kbprb

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Article Info
Article ID : 902274
Revision : 4
Created on : 4/23/2018
Published on : 4/23/2018
Exists online : False
Views : 261