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When you try to shut down a Windows Server 2003-based computer that uses an NDIS network adapter in an iSCSI boot configuration, you experience a Stop error


View products that this article applies to.

Symptoms

Consider the following scenario. A Microsoft Windows Server 2003-based computer uses an iSCSI boot configuration. This computer also uses a Network Driver Interface Specification (NDIS) network adapter to access the iSCSI boot disk. When you try to shut down the computer, you experience a Stop error. Additionally, debugging information is not written to a memory dump file as expected.

Note When this problem occurs, you may experience data corruption.

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Cause

This problem occurs because of a bug in the NDIS driver (Ndis.sys). Because of this bug, NDIS devices are not included in the paging path when you use an iSCSI device to start the computer. Because the NDIS network adapter is not included in the paging path, the operating system does not recognize the network adapter as a critical device. Therefore, the network adapter may shut down while important I/O disk operations are still occurring.

In an iSCSI boot configuration, the network is of critical importance because the operating system files are available only at a network location. Additionally, these files can be accessed only by using the NDIS network adapter. Therefore, if the NDIS network adapter shuts down before Windows has finished accessing system files, you experience a Stop error, data corruption, or both.

Note Debugging information is typically written to the iSCSI disk. However, because the network adapter is no longer running, the iSCSI disk is unavailable.

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Resolution

Update information

The following files are available for download from the Microsoft Download Center:

Download the Windows Server 2003 (KB902113) package now.
Download the Windows Server 2003 for Itanium-based Systems (KB902113) package now.
Download the Windows Server 2003 x64 Edition (KB902113) package now.

Release Date: December 19, 2006

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

You must be running Windows Server 2003 Service Pack 1 (SP1) to apply this update.

Note x64-based versions of Windows Server 2003 do not require this service pack to apply this update.

Restart requirement

You must restart your computer after you apply this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ndis.sys5.2.3790.2617187,39213-Jan-200602:37x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ndis.sys5.2.3790.2617335,36013-Jan-200603:57x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ndis.sys5.2.3790.2617574,46413-Jan-200603:56IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

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Keywords: KB902113, kbexpertiseinter, kbqfe, kbwinserv2003presp2fix, kbwinserv2003sp2fix, atdownload

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Article Info
Article ID : 902113
Revision : 9
Created on : 3/28/2007
Published on : 3/28/2007
Exists online : False
Views : 258