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Some custom printer properties may be unavailable in a 64-bit version of Windows Server 2003 or Windows XP


View products that this article applies to.

Symptoms

When you connect a printer to a computer that is running a 64-bit version of Microsoft Windows Server 2003 or Microsoft Windows XP, some custom printer properties may be unavailable. Because of this problem, you may experience one or more of the following symptoms:
  • Some programs cannot optimize the printer and use all the printer's capabilities.
  • You cannot print.
  • Print quality is poor.
  • You receive an "insufficient memory" error message.
For example, you may experience these problems when you try to print to an HP DesignJet printer from Autodesk's AutoCAD.

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Cause

Some custom printer queries are not supported in the 64-bit versions of Windows Server 2003 and Windows XP. Programs such as AutoCAD use custom printer queries to print large format complex drawings.

The problem occurs because the pOutput <> pointer that is received by the DrvDeviceCapabilities function in the printer driver is always NULL. The pointer is NULL regardless of whether the program has assigned a valid pointer when the program calls the DeviceCapabilities function. Therefore, the program cannot obtain the information from the printer that enables the program to optimize the Graphics Device Interface (GDI).

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x64-based versions or Windows XP Professional x64 Edition

   Date         Time   Version            Size    File name      Platform
   ----------------------------------------------------------------------
   13-Jun-2005  18:28  5.2.3790.2463      38,400  Splwow64.exe   x64

Windows Server 2003, Itanium-based versions

   Date         Time   Version            Size    File name      Platform
   ----------------------------------------------------------------------
   13-Jun-2005  18:28  5.2.3790.2463      72,192  Splwow64.exe   IA-64


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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site: Note The x64-based versions of Windows Server 2003 and of Windows XP Professional are based on the Windows Server 2003 code tree. Service and support activities for Windows XP Professional x64 Edition use the Windows Server 2003 tree and do not use the Windows XP client tree. For more information about the x64-based versions of Windows Server 2003 and of Windows XP Professional x64 Edition, click the following article number to view the article in the Microsoft Knowledge Base:
888733 A description of the x64-based versions of Windows Server 2003 and of Windows XP Professional x64 Edition
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbfix, kbbug, kbwinxppresp3fix, kberrmsg, kbqfe, kbhotfixserver, kbwinserv2003sp2fix, KB902066

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Article Info
Article ID : 902066
Revision : 6
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 360