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A memory leak occurs in the Lsass.exe process on a Windows XP-based or a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use a DCOM program that consists of a client computer-side program and a server-side program.
  • You install the server-side program on a Microsoft Windows XP-based or a Microsoft Windows Server 2003-based computer.
  • The DCOM program uses Connect level security that is set by using the Dcomcnfg.exe utility.
  • You run the client computer-side program against the server-side program.
In this scenario, a memory leak occurs in the Lsass.exe process on the server. You have to restart the server when this problem occurs.

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Cause

This problem occurs because of a memory leak in the negotiate security package.

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Resolution

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Windows XP Service Pack 2 (SP2) installed on the computer.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.1.2600.2745726,01624-Aug-200509:27x86

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Windows Server 2003 service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Windows Server 2003 hotfix information

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Eventlog.dll5.2.3790.21264,00018-Oct-200414:12x86NoneRTMQFE
Lsasrv.dll5.2.3790.359801,28029-Jun-200505:33x86NoneRTMQFE
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.24761,565,18428-Jun-200517:35x64
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Eventlog.dll5.2.3790.212167,93628-Jun-200517:35IA-64NoneRTMQFE
Lsasrv.dll5.2.3790.3592,038,27228-Jun-200517:35IA-64NoneRTMQFE
Windows Server 2003 Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTime
Lsasrv.dll5.2.3790.2476821,76029-Jun-200505:37
Windows Server 2003 Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTime
Lsasrv.dll5.2.3790.24761,565,18429-Jun-200506:05
Windows Server 2003 Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTime
Lsasrv.dll5.2.3790.24762,164,22429-Jun-200506:05

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbwinxpsp3fix, kbwinxppresp3fix, kbwinserv2003presp2fix, kbexpertiseadvanced, kbbug, kbfix, kbHotfixServer, kbqfe, KB902058

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Article Info
Article ID : 902058
Revision : 4
Created on : 10/9/2011
Published on : 10/9/2011
Exists online : False
Views : 745